Author Topic: Code Completion cannot list project headers  (Read 1486 times)

Offline blazar

  • Single posting newcomer
  • *
  • Posts: 4
Code Completion cannot list project headers
« on: May 06, 2014, 01:20:51 pm »
I have installed Code::Blocks 13.12 on CentOS 5, 64 bit.

The Code Completion is working, but after typing
Code: [Select]
#include " it only list headers in /usr/include.
Swtich back to 10.05, it can list project headers in any sub-directories from project root path just after typing #include " in relative path.

For example:
project root is: project/P1/
header is: project/P1/src/ex1.hpp
expected code completion:
Code: [Select]
#include "src/ex1.hpp"
I use custom Makefile, an established project from 10.05, and it seems works at first.

I have tried to check setting of project and/or compiler but still cannot figure it out.
Tried modifying Project->Properties->C/C++ Parser Options->Additional search paths and Settings->Compiler->Global Compiler Settings->Search Paths but in vain.
Also tried File Manager->Files->Make root on project root path.
Though I think if the headers is in project sub-directories it should work without setting and modify compiler is not correct: it's for every projects.
Anyway non of above works.

I've been switching to 13.12 for few days. I remember that it was working correctly and it seems suddenly stop to work in that way.
Typing include headers is a very common usage, I would notice if it stop worked before.

I even try to re-install Code::Blocks 13.12, but it still behave the same.

In fact I switched to 13.12 because 10.05's code completion "sometimes" stops working. I was happy at first it seems work greatly and thought 13.12 fix the Code Completion...