Author Topic: error during autotools (make) i don't understand  (Read 3579 times)

Offline gilmry

  • Single posting newcomer
  • *
  • Posts: 3
error during autotools (make) i don't understand
« on: September 14, 2013, 06:31:59 pm »
Hi everybody !

Sorry for my bad english !

I tried to install CB from the source with autotools....

In the text file attached there is the trace of my term...

I'm on ubuntu 12.04 LTS....

thank you for your help !

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: error during autotools (make) i don't understand
« Reply #1 on: September 14, 2013, 06:55:08 pm »
It looks like you have ansi-packages of wxWidgets installed (or at least wx-config uses them as default), but you need the unicode (non-ansi) packages.

Offline gilmry

  • Single posting newcomer
  • *
  • Posts: 3
Re: error during autotools (make) i don't understand
« Reply #2 on: September 14, 2013, 08:10:48 pm »
thank you for the help !

In details : in the wxxwidget 2.8  there is an option in "./configure" : "--enable unicode",

i'm trying with the 2.9 version where the option in "./configure" is "--disable unicode",

then with the wx-config command there is an option "--unicode=yes".....

I think that the problem is solved....

Again, thank you very much...!!!


Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: error during autotools (make) i don't understand
« Reply #3 on: September 14, 2013, 08:27:48 pm »
thank you for the help !

In details : in the wxxwidget 2.8  there is an option in "./configure" : "--enable unicode",

i'm trying with the 2.9 version where the option in "./configure" is "--disable unicode",

then with the wx-config command there is an option "--unicode=yes".....

I think that the problem is solved....

Again, thank you very much...!!!



Why do you use self-compiled wxWidgets ?
You should only do this if you really know what you do and you realy, really need it.

As normal user (and normal developer), you should use the wxWidgets shipped with your distro (it's 2.8.12 on Ubuntu 12.04).

Offline gilmry

  • Single posting newcomer
  • *
  • Posts: 3
Re: error during autotools (make) i don't understand
« Reply #4 on: September 14, 2013, 09:07:24 pm »
ok thanks, i've just finished to install some dependences (boost...gamin...hunspell....) the "./configure" is ok, i've launched the "make"...
Now i "pray"... ;-)
I'm a junior dev whose need the last version of CB for the C++11 ability.... i know a little bit in sysadmin and netAdmin but in devel it's huge and fantastic what i need to learn....

Thanks for all your lights !

ps : if it fail, i'll retry with 2.8 with unicode....


Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: error during autotools (make) i don't understand
« Reply #5 on: September 14, 2013, 09:42:41 pm »
Do not build C::Bwith wx2.9 or higher (3.0 is short before rc1).
C::B still has many, many issues especially with wxSmith, even if I committed some wx2.9 related fixes the last days.