Author Topic: wxSmith source file path problem  (Read 2445 times)

Offline ison

  • Single posting newcomer
  • *
  • Posts: 2
wxSmith source file path problem
« on: August 05, 2012, 11:23:40 pm »
Hello,
I have some problems with setting valid wxSmith application file path. I had my project refactored and needed to make a new wxSmith project but copy old .wxs file to keep my application layout. All seemed to be working fine until I moved all source files to a different catalogue (I had to remove my application source files from project, move them and add them again). After choosing "wxSmith->Configure wsSmith for current project" and selecting file (the only one shown) it didn't seem to work. Whenever I change something in wxSmith .wxs file nothing is changed in my application source file. Am I doing something wrong? Now when I go to "wxSmith->Configure wsSmith for current project" it shows my application frame class name correctly, so it should work, but it doesn't.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: wxSmith source file path problem
« Reply #1 on: August 05, 2012, 11:50:07 pm »
There is no way to do it with the gui.
You need to tweak your project-file manually.

Make a backup of the file, open it in a text-editor and fix the paths to the source and header files in the section "Extensions -> wxsmith -> resources".

Offline ison

  • Single posting newcomer
  • *
  • Posts: 2
Re: wxSmith source file path problem
« Reply #2 on: August 06, 2012, 12:26:19 am »
Thanks a lot! It worked :)
I thought that it was the path I was setting in wxSmith options, strange it didn't work via GUI.