Author Topic: wxsmith opengl canvas  (Read 6325 times)

Offline julesd

  • Single posting newcomer
  • *
  • Posts: 3
wxsmith opengl canvas
« on: October 05, 2010, 07:20:13 am »
How do I get this to work.
When I add the opengl canvas I get compile error.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5302
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: wxsmith opengl canvas
« Reply #1 on: October 05, 2010, 07:40:18 am »
When I add the opengl canvas I get compile error.
No idea about your problem unless more information supplied.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: wxsmith opengl canvas
« Reply #2 on: October 05, 2010, 07:40:46 am »
Do you think we have the second sight ?

Your post gives nearly no information needed to be able to help you.

Which OS, which version of wxwidgets, exact error-message ...

Offline julesd

  • Single posting newcomer
  • *
  • Posts: 3
Re: wxsmith opengl canvas
« Reply #3 on: October 05, 2010, 08:42:21 am »
Windows 7 64 bit
code block 10.05 svn 6634
MinGW 4.5
wxwidgets 2.8.11.02

When I create forms with wxsmith and compile everything works fine.
But when I add a opengl canvas I get


||warning: auto-importing has been activated without --enable-auto-import specified on the command line.|
obj\Debug\ytryetMain.o||In function `ytryetFrame':|
D:\Users\Admin\Documents\CodeBlocks\ytryet\ytryetMain.cpp|75|undefined reference to `_imp___ZN10wxGLCanvasC1EP8wxWindowiRK7wxPointRK6wxSizelRK8wxStringPiRK9wxPalette'|
||Info: resolving vtable for __cxxabiv1::__si_class_type_info by linking to __imp___ZTVN10__cxxabiv120__si_class_type_infoE |
||Info: resolving vtable for __cxxabiv1::__class_type_info by linking to __imp___ZTVN10__cxxabiv117__class_type_infoE |
||=== Build finished: 1 errors, 1 warnings (0 minutes, 1 seconds) ===|
« Last Edit: October 05, 2010, 08:46:18 am by julesd »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13069
    • Travis build status
Re: wxsmith opengl canvas
« Reply #4 on: October 05, 2010, 09:44:39 am »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline julesd

  • Single posting newcomer
  • *
  • Posts: 3
Re: wxsmith opengl canvas
« Reply #5 on: October 05, 2010, 06:53:53 pm »
When I use the project wizard select wxwidgets project, then use wxsmith with frame base.
I add a panel, then go to advance and select wxgl canvas and add that, but when I run it I get that error.

Every other object seems to work fine, it's just when I add the wlcanvas.
« Last Edit: October 05, 2010, 07:03:00 pm by julesd »

Offline gd_on

  • Lives here!
  • ****
  • Posts: 588
Re: wxsmith opengl canvas
« Reply #6 on: October 05, 2010, 08:08:07 pm »
As you don't give details, it's not obvious to help you. May be you should generate wxwidgets with the option USE_OPENGL=1 because by default, it's not generated with this support.

gd_on
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7065
    • My Best Post
Re: wxsmith opengl canvas
« Reply #7 on: October 05, 2010, 08:41:26 pm »
« Last Edit: October 05, 2010, 09:35:24 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org