Author Topic: [SOLVED]code completion partially working  (Read 13901 times)

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
[SOLVED]code completion partially working
« on: August 16, 2010, 11:38:53 am »
Hello all,

My configuration:
- Debian sid
- CodeBlocks svn6476 (http://apt.jenslody.de/ packets)
- WxWidgets 2.8.10 (debian sid packets)

I'm using codeblocks for a while now and I haven't succeed with code completion.
As it seems that it's working "out of the box" for many, I must missing something...

What is working:
name completion:


class attributes or method for external libs (here with led widgets: libwxadditions28 from wxformbuilder)


class attributes or method from project


What isn't working is the completion of the wxwidgets classes (here with a statictext for example)


My settings:
compiler


linker


As indicated in
http://wiki.codeblocks.org/index.php?title=FAQ#Q:_How_do_I_get_Code_Completion_to_work.3F
I've tried to add path to wxwidgets includes to C/C++ parser (because wxwidgets includes path is indicated with "`wx-config --cflags --debug=yes`") but with no sucess  :?


If someone have an idea ?

Thanks in advance,

Éric.
« Last Edit: August 23, 2010, 09:33:22 pm by Eric »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5242
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: code completion partially working
« Reply #1 on: August 16, 2010, 02:56:32 pm »
Did you mean that only static member variables failed in code completion?
I just do a test with the latest cc_branch, I just define a static member variable in a class, and it works fine.  :D
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #2 on: August 16, 2010, 03:28:39 pm »
Did you mean that only static member variables failed in code completion?
I just do a test with the latest cc_branch, I just define a static member variable in a class, and it works fine.  :D
yes and no...

If I do:
Code: [Select]
wxString s;
s.
give me completion choice for wxString method and that's OK.

But if I'm using a derived class that doesn't work.
For example:
- I've a base class (generated by wxFormbuilder) "Panel_E_S_TOR"
Code: [Select]
///////////////////////////////////////////////////////////////////////////
// C++ code generated with wxFormBuilder (version Aug 28 2009)
// http://www.wxformbuilder.org/
//
// PLEASE DO "NOT" EDIT THIS FILE!
///////////////////////////////////////////////////////////////////////////

#ifndef __Panel_E_S_TOR__
#define __Panel_E_S_TOR__

#include <wx/string.h>
#include <wx/stattext.h>
#include <wx/gdicmn.h>
#include <wx/font.h>
#include <wx/colour.h>
#include <wx/settings.h>
#include <wx/awx/led.h>
#ifdef __VISUALC__
#include <wx/link_additions.h>
#endif //__VISUALC__
#include <wx/sizer.h>
#include <wx/statbox.h>
#include <wx/panel.h>

///////////////////////////////////////////////////////////////////////////


///////////////////////////////////////////////////////////////////////////////
/// Class Panel_E_S_TOR
///////////////////////////////////////////////////////////////////////////////
class Panel_E_S_TOR : public wxPanel
{
private:

protected:
wxStaticText* m_staticTextNum;
awxLed* m_awxLed;

// Virtual event handlers, overide them in your derived class
virtual void OnLedDClick( wxMouseEvent& event ) { event.Skip(); }


public:

Panel_E_S_TOR( wxWindow* parent, wxWindowID id = wxID_ANY, const wxPoint& pos = wxDefaultPosition, const wxSize& size = wxSize( 110,180 ), long style = wxTAB_TRAVERSAL );
~Panel_E_S_TOR();

};

#endif //__Panel_E_S_TOR__

- and a derived class "EvtPanel_E_S_TOR" from "Panel_E_S_TOR"
Code: [Select]
#ifndef __EvtPanel_E_S_TOR__
#define __EvtPanel_E_S_TOR__

/**
@file
Subclass of Panel_E_S_TOR, which is generated by wxFormBuilder.
*/

#include "Panel_E_S_TOR.h"

class EvtFramePrincipal;

/** Implementing Panel_E_S_TOR */
class EvtPanel_E_S_TOR : public Panel_E_S_TOR
{
protected:
// Handlers for Panel_E_S_TOR events.
void OnLedDClick( wxMouseEvent& event );

public:
/** Constructor */
EvtPanel_E_S_TOR( wxWindow* parent, int num ,EvtFramePrincipal* frame);
    void Set();
    void Reset();

private:
    int m_numero;
    EvtFramePrincipal* IHM;
    bool etat;

};

#endif // __EvtPanel_E_S_TOR__
I don't have completion for "m_staticTextNum" in "EvtPanel_E_S_TOR.cpp":


And if I'm trying to create a new wxStaticText (like i've done previously with wxString):

the code completion gives me choices but not "wxStaticText"...

Strange...
Have I done something wrong ?

Éric.


Offline blueshake

  • Regular
  • ***
  • Posts: 459
Re: code completion partially working
« Reply #3 on: August 16, 2010, 04:03:23 pm »
try the cc_branch and may fix your trouble. :D
Keep low and hear the sadness of little dog.
I fall in love with a girl,but I don't dare to tell her.What should I do?

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5242
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: code completion partially working
« Reply #4 on: August 16, 2010, 04:35:25 pm »
it works here, see the image below:( I just use your sample code ), ccbranch and windowx XP, wxWidgets 2.8.11
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #5 on: August 16, 2010, 04:51:10 pm »
try the cc_branch and may fix your trouble. :D

it works here, see the image below:( I just use your sample code ), ccbranch and windowx XP, wxWidgets 2.8.11


OK so I have to use the "codecompletion_refactoring" branche (in http://svn.berlios.de/svnroot/repos/codeblocks/branches/) not the trunk ?

Éric.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5242
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: code completion partially working
« Reply #6 on: August 17, 2010, 01:17:52 am »

OK so I have to use the "codecompletion_refactoring" branche (in http://svn.berlios.de/svnroot/repos/codeblocks/branches/) not the trunk ?

Éric.

Yes.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #7 on: August 17, 2010, 09:08:42 am »

OK so I have to use the "codecompletion_refactoring" branche (in http://svn.berlios.de/svnroot/repos/codeblocks/branches/) not the trunk ?

Éric.

Yes.
Thank you.
So I've downloaded the branch with
"svn checkout svn://svn.berlios.de/codeblocks/branches/codecompletion_refactoring".

But there are errors during the build (in "wxpropgrid"):
Code: [Select]
...
make[4]: quittant le répertoire « /home/eric/Téléchargements/codeblocks/codecompletion_refactoring/src/sdk/wxscintilla »
Making all in wxpropgrid
make[4]: entrant dans le répertoire « /home/eric/Téléchargements/codeblocks/codecompletion_refactoring/src/sdk/wxpropgrid »
/bin/sh ../../../libtool  --tag=CXX   --mode=compile x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -I../../../src/sdk/wxpropgrid/include -DWXMAKINGLIB_PROPGRID -DwxPG_USE_WXMODULE=0 -Ulinux -Uunix  -O2 -ffast-math -DCB_AUTOCONF -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT advprops.lo -MD -MP -MF .deps/advprops.Tpo -c -o advprops.lo `test -f './src/advprops.cpp' || echo './'`./src/advprops.cpp
libtool: compile:  x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -I../../../src/sdk/wxpropgrid/include -DWXMAKINGLIB_PROPGRID -DwxPG_USE_WXMODULE=0 -Ulinux -Uunix -O2 -ffast-math -DCB_AUTOCONF -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT advprops.lo -MD -MP -MF .deps/advprops.Tpo -c ./src/advprops.cpp  -fPIC -DPIC -o .libs/advprops.o
./src/advprops.cpp:450:56: error: macro "WX_PG_DECLARE_EDITOR_CLASS" passed 1 arguments, but takes just 0
./src/advprops.cpp:1527:71: error: macro "WX_PG_IMPLEMENT_CUSTOM_COLOUR_PROPERTY_USES_WXCOLOUR2" requires 6 arguments, but only 5 given
./src/advprops.cpp:253: error: ‘wxPGSpinCtrlEditor’ has not been declared
...

I've tried to build via:
- "./debian/rules build"
- "./bootstrap;./configure --with-contrib-plugins=all;make"
- codeblocks project in src: CodeBlocks-unix.cbp
But all three gave up with the same errors.

Any idea ?

My configuration:
- Debian sid amd64
- WxWidgets 2.8.10 (debian sid packets)

Éric.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #8 on: August 18, 2010, 05:53:09 pm »
Hello,

I've just tried to compile the last svn of the "codecompletion_refactoring" branch and the build stops with the same error.
I'm using wxw2.8.10. Does this branch requires 2.9 or another ?

Thanks in advance.
Éric.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: code completion partially working
« Reply #9 on: August 18, 2010, 07:23:00 pm »
Hello,

I've just tried to compile the last svn of the "codecompletion_refactoring" branch and the build stops with the same error.
I'm using wxw2.8.10. Does this branch requires 2.9 or another ?

Thanks in advance.
Éric.

Works fine here with wxWidgets 2.8.10 from debian testing (squeeze).
wx-2.9 does not work, because it includes wxpropgrid and conflicts with the wxpropgrid included in our sources.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #10 on: August 18, 2010, 08:57:52 pm »
Hello,

I've just tried to compile the last svn of the "codecompletion_refactoring" branch and the build stops with the same error.
I'm using wxw2.8.10. Does this branch requires 2.9 or another ?

Thanks in advance.
Éric.

Works fine here with wxWidgets 2.8.10 from debian testing (squeeze).
wx-2.9 does not work, because it includes wxpropgrid and conflicts with the wxpropgrid included in our sources.
So, what's going wrong ?
As I've said before:
I've downloaded the branch with
"svn checkout svn://svn.berlios.de/codeblocks/branches/codecompletion_refactoring".

And during the build there are errors (in "wxpropgrid"):
Code: [Select]
...
make[4]: quittant le répertoire « /home/eric/Téléchargements/codeblocks/codecompletion_refactoring/src/sdk/wxscintilla »
Making all in wxpropgrid
make[4]: entrant dans le répertoire « /home/eric/Téléchargements/codeblocks/codecompletion_refactoring/src/sdk/wxpropgrid »
/bin/sh ../../../libtool  --tag=CXX   --mode=compile x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -I../../../src/sdk/wxpropgrid/include -DWXMAKINGLIB_PROPGRID -DwxPG_USE_WXMODULE=0 -Ulinux -Uunix  -O2 -ffast-math -DCB_AUTOCONF -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT advprops.lo -MD -MP -MF .deps/advprops.Tpo -c -o advprops.lo `test -f './src/advprops.cpp' || echo './'`./src/advprops.cpp
libtool: compile:  x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -pthread -I../../../src/sdk/wxpropgrid/include -DWXMAKINGLIB_PROPGRID -DwxPG_USE_WXMODULE=0 -Ulinux -Uunix -O2 -ffast-math -DCB_AUTOCONF -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT advprops.lo -MD -MP -MF .deps/advprops.Tpo -c ./src/advprops.cpp  -fPIC -DPIC -o .libs/advprops.o
./src/advprops.cpp:450:56: error: macro "WX_PG_DECLARE_EDITOR_CLASS" passed 1 arguments, but takes just 0
./src/advprops.cpp:1527:71: error: macro "WX_PG_IMPLEMENT_CUSTOM_COLOUR_PROPERTY_USES_WXCOLOUR2" requires 6 arguments, but only 5 given
./src/advprops.cpp:253: error: ‘wxPGSpinCtrlEditor’ has not been declared
...

I've tried to build via:
- "./debian/rules build"
- "./bootstrap;./configure --with-contrib-plugins=all;make"
- codeblocks project in src: CodeBlocks-unix.cbp
But all three gave up with the same errors.

Any idea ?

My configuration:
- Debian sid amd64
- WxWidgets 2.8.10 (debian sid packets)

Éric.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: code completion partially working
« Reply #11 on: August 18, 2010, 10:02:25 pm »
Something must be messed up on your system.

As first you can place the mouse over WX_PG_DECLARE_EDITOR_CLASS in src/sdk/wxpropgrid/src/advprops.cpp:450, right-click and chose "Find declaration" and see what it shows you.

Normally WX_PG_DECLARE_EDITOR_CLASS is declared in  src/sdk/wxpropgrid/include/wx/propgrid/editors.h:202 and takes exactly one argument.

You can also check the other errors the same way.

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #12 on: August 19, 2010, 05:24:31 pm »
Something must be messed up on your system.

As first you can place the mouse over WX_PG_DECLARE_EDITOR_CLASS in src/sdk/wxpropgrid/src/advprops.cpp:450, right-click and chose "Find declaration" and see what it shows you.

Normally WX_PG_DECLARE_EDITOR_CLASS is declared in  src/sdk/wxpropgrid/include/wx/propgrid/editors.h:202 and takes exactly one argument.

You can also check the other errors the same way.

Thank you, that's it.

I've installed wxaddttions from wxformbuilder.
The additions includes a version of wxpropgrid which conflict the included one...
So now, I can build but there is another issue:
I've tried to load an existing project and when the project is loaded, as sson as I move the mouse the program segfault:

Code: [Select]
[email protected]:~$ /usr/local/bin/codeblocks
Initialize EditColourSet .....

...

Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Starting batch parsing for Project essai...
Get Headers: /usr/lib/wx/include/gtk2-unicode-release-2.8/ , 1
Get Headers: /usr/include/wx-2.8/ , 591
Get Headers: /usr/include/c++/4.4/ , 578
Get Headers: /usr/include/c++/4.4/x86_64-linux-gnu/ , 46
Get Headers: /usr/include/c++/4.4/backward/ , 8
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Get Headers: /usr/local/include/ , 280
Get Headers: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include/ , 27
Get Headers: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include-fixed/ , 4
Get Headers: /usr/include/x86_64-linux-gnu/ , 2
codeblocks: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.0.
Erreur de segmentation

As there are in reading configuration (keybinder...), I've removed my ~/.codeblocks directory and start with a new project wxsmith based. No segfault this time but the program meaves anyway:
Code: [Select]
[email protected]:~$ /usr/local/bin/codeblocks
Initialize EditColourSet .....
Initialize EditColourSet: done.
Loading toolbar...
Debugger: loaded
NassiShneidermanPlugin: loaded
DoxyBlocks: loaded
wxSmith: loaded
wxSmithMime: loaded
AStylePlugin: loaded
SymTab: loaded
wxSmithContribItems: loaded
HexEditor: loaded
RegExTestbed: loaded
lib_finder: loaded
ProjectsImporter: loaded
CodeStat: loaded
ToDoList: loaded
Autosave: loaded
Cscope: loaded
FilesExtensionHandler: loaded
EditorTweaks: loaded
ScriptedWizard: loaded
cbKeyBinder: loaded
Compiler: loaded
Profiler: loaded
OpenFilesList: loaded
AutoVersioning: loaded
HeaderFixup: loaded
copystrings: loaded
cbDragScroll: loaded
CodeSnippets: loaded
wxSmithAui: loaded
Valgrind: loaded
Exporter: loaded
ThreadSearch: loaded
BYOGames: loaded
EnvVars: loaded
IncrementalSearch: loaded
ClassWizard: loaded
CppCheck: loaded
HelpPlugin: loaded
BrowseTracker: loaded
CodeCompletion: loaded
Cccc: loaded
CB_Koders: loaded
MouseSap: loaded
Debugger plugin activated
NassiShneidermanPlugin plugin activated
DoxyBlocks plugin activated
wxSmith plugin activated
wxSmith - MIME plugin plugin activated
Source code formatter (AStyle) plugin activated
Symbol Table Plugin plugin activated
wxSmith - Contrib Items plugin activated
HexEditor plugin activated
Regular expressions testbed plugin activated
Library finder plugin activated
Foreign projects importer plugin activated
Code statistics plugin activated
Todo List plugin activated
Autosave plugin activated
Cscope plugin activated
Files extension handler plugin activated
Editor Tweaks plugin: Building menu
Editor Tweaks plugin: edit menu not found
EditorTweaks plugin activated
Project wizard added for 'Empty project'
Project wizard added for 'Console application'
Project wizard added for 'D application'
Project wizard added for 'FLTK project'
Project wizard added for 'GLFW project'
Project wizard added for 'GLUT project'
Project wizard added for 'GTK+ project'
Project wizard added for 'Irrlicht project'
Project wizard added for 'Lightfeather project'
Project wizard added for 'OpenGL project'
Project wizard added for 'Ogre project'
Project wizard added for 'Code::Blocks plugin'
Project wizard added for 'QT4 project'
Project wizard added for 'SDL project'
Project wizard added for 'SFML project'
Project wizard added for 'Static library'
Project wizard added for 'Shared library'
Project wizard added for 'wxWidgets project'
Build-target wizard added for 'Console'
Build-target wizard added for 'Static library'
Build-target wizard added for 'wxWidgets'
Project wizard added for 'ARM Project'
Project wizard added for 'AVR Project'
Project wizard added for 'TriCore Project'
Project wizard added for 'PowerPC Project'
File(s) wizard added for 'Empty file'
File(s) wizard added for 'C/C++ source'
File(s) wizard added for 'C/C++ header'
Scripted wizard plugin activated
Keyboard shortcuts plugin activated
Added compiler "GNU GCC Compiler"
Added compiler "Intel C/C++ Compiler"
Added compiler "SDCC Compiler"
Added compiler "Tiny C Compiler"
Added compiler "GDC D Compiler"
Added compiler "Digital Mars D Compiler"
Added compiler "GNU ARM GCC Compiler"
Added compiler "GNU AVR GCC Compiler"
Added compiler "GNU GCC Compiler for PowerPC"
Added compiler "GNU GCC Compiler for TriCore"
Compiler plugin activated
Code profiler plugin activated
Open files list plugin activated
AutoVersioning plugin activated
Header Fixup plugin activated
Copy Strings to clipboard plugin activated
DragScroll plugin activated
Code snippets plugin activated
wxSmith - Aui plugin activated
Valgrind plugin activated
Source Exporter plugin activated
ThreadSearch plugin activated
BYO Games plugin activated
Environment variables plugin activated
IncrementalSearch plugin activated
Class wizard plugin activated
CppCheck plugin activated
Help plugin plugin activated
BrowseTracker plugin activated
Code completion plugin activated
Cccc plugin activated
Koders query plugin activated
MouseSap plugin activated
Initializing plugins...
Generated file /home/eric/Desktop/essai/essaiApp.h
Project's base path: /home/eric/Desktop/essai/
Project's common toplevel path: /home/eric/Desktop/essai/
Generated file /home/eric/Desktop/essai/essaiApp.cpp
Generated file /home/eric/Desktop/essai/essaiMain.h
Generated file /home/eric/Desktop/essai/essaiMain.cpp
Generated file /home/eric/Desktop/essai/wxsmith/essaiframe.wxs
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Add new parser for project essai...
Caching result of `wx-config --cflags`
Cached
Caching result of `wx-config --libs`
Cached
Caching GCC dir: /usr/include/c++/4.4
Caching GCC dir: /usr/include/c++/4.4/x86_64-linux-gnu
Caching GCC dir: /usr/include/c++/4.4/backward
Caching GCC dir: /usr/local/include
Caching GCC dir: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include
Caching GCC dir: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include-fixed
Caching GCC dir: /usr/include/x86_64-linux-gnu
Caching GCC dir: /usr/include
Passing list of files to batch-parser.
Header to parse up-front: '/usr/include/c++/4.4/cstddef'
Header to parse up-front: '/usr/include/wx-2.8/wx/defs.h'
Header to parse up-front: '/usr/include/wx-2.8/wx/dlimpexp.h'
Header to parse up-front: '/usr/include/wx-2.8/wx/toplevel.h'
Add up-front parsing 4 file(s) for Project essai...
Add batch-parsing 4 file(s) for Project essai...
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Starting batch parsing for Project essai...
Get Headers: /usr/lib/wx/include/gtk2-unicode-release-2.8/ , 1
Get Headers: /usr/include/wx-2.8/ , 591
Text seems to be pure ASCII!
We use user specified encoding: Unicode 8 bit (UTF-8) (ID: 41)
Final encoding detected: Unicode 8 bit (UTF-8) (ID: 41)
Get Headers: /usr/include/c++/4.4/ , 578
Get Headers: /usr/include/c++/4.4/x86_64-linux-gnu/ , 46
Get Headers: /usr/include/c++/4.4/backward/ , 8
Get Headers: /usr/local/include/ , 280
Get Headers: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include/ , 27
Get Headers: /usr/lib/gcc/x86_64-linux-gnu/4.4.5/include-fixed/ , 4
Get Headers: /usr/include/x86_64-linux-gnu/ , 2
codeblocks: ../../src/xcb_io.c :183 : process_responses:  L'assertion « !(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0)) » a échoué.
Abandon


An idea ?

Thank in advance,

Éric.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: code completion partially working
« Reply #13 on: August 19, 2010, 07:15:10 pm »
I've tried to load an existing project and when the project is loaded, as sson as I move the mouse the program segfault:

Which branch (I guess cc, because I get the same here, debian 64bit) ?

Offline Eric

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: code completion partially working
« Reply #14 on: August 19, 2010, 07:18:41 pm »
I've tried to load an existing project and when the project is loaded, as sson as I move the mouse the program segfault:

Which branch (I guess cc, because I get the same here, debian 64bit) ?

Yes code_completion branch.
Debian amd64 and wxw 2.8.10

Éric.