Author Topic: cannot find -lwxmsw26  (Read 3227 times)

hforbess

  • Guest
cannot find -lwxmsw26
« on: November 18, 2005, 05:48:30 pm »
I found another post that explains that I need to take the -l from -lwxmsw26 and all my libraries, but I dont see where to do this.

im using WinXP
Gnu GCC compiler
C::B v1.0 rc2

anybody have any idea?

Offline cyberkoa

  • Plugin developer
  • Almost regular
  • ****
  • Posts: 145
    • http://
Re: cannot find -lwxmsw26
« Reply #1 on: November 18, 2005, 06:16:42 pm »
I found another post that explains that I need to take the -l from -lwxmsw26 and all my libraries, but I dont see where to do this.

im using WinXP
Gnu GCC compiler
C::B v1.0 rc2

anybody have any idea?
I try to understand your problem ..

is this problem appear when you are building a wx-widgets program or running Codeblocks ?

If is building/linking a program , you need to go to Project/Build Option/ Directory > Linker to check your linker path settings.

And you need to build your own wxwidgets if you do not want to use the wxmsw that come with CB .



Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: cannot find -lwxmsw26
« Reply #2 on: November 18, 2005, 07:09:19 pm »
It depends what you do. You can either tell the linker what you want using the "Link libraries" field to the left, or to "Other linker options" to the right.

Using "Link libraries", you have to remove the -l. Using the "Other linker options" field, you must have it:



Note that the image shows both options, you obviously only need one of them (using "Link libraries" is recommended).

EDIT:
This assumes you have set up the linker's directories properly, if that is not the case, the linker won't find anything either, of course.
« Last Edit: November 18, 2005, 07:12:04 pm by thomas »
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

hforbess

  • Guest
Re: cannot find -lwxmsw26 : Solved
« Reply #3 on: November 18, 2005, 07:49:47 pm »
apparently, I had to compile these myself.
http://wiki.codeblocks.org/index.php/Compiling_wxWidgets_2.6.1_to_develop_Code::Blocks_%28MSW%29

Then I just tossed the dll's into C:\windows\system32

Works fine now. :D

Thanks

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: cannot find -lwxmsw26 : Solved
« Reply #4 on: November 18, 2005, 08:30:12 pm »
Then I just tossed the dll's into C:\windows\system32
Although this works, it is a Bad Idea.

Better keep them in the wxWidgets directory along with the headers and set the compiler/linker paths correctly. This is safer, cleaner, and more flexible. Tossing stuff into Windows' path can have unforeseen nasty side effects, too, so avoid that whenever you can.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."