Author Topic: Added the missing dialogues to wxSmith.  (Read 3910 times)

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Added the missing dialogues to wxSmith.
« on: May 27, 2010, 02:44:12 am »
Added the following dialogues to wxSmith:

wxFindReplace
wxFontDialog
wxMessageDialog
wxPageSetupDialog
wxPasswordEntryDialog
wxPrintDialog
wxProgressDialog
wxRichTextFormattingDialog
wxRichTextStyleOrganiserDialog
wxTextEntryDialog

Also aligned symbol picker dlg image with the standard style and fixed the colour clash on Linux and arranged all icons logically.

Created against SVN 6276.
Images and patch are attached.

Cryo.



[attachment deleted by admin]
« Last Edit: May 27, 2010, 02:56:53 am by Cryogen »

Offline seb_seb0

  • Almost regular
  • **
  • Posts: 166
Re: Added the missing dialogues to wxSmith.
« Reply #1 on: May 30, 2010, 09:00:07 pm »
Hello,

in your patch, you forgot to add the modified version of the wxSmith.cbp file.
The new files you have added were therefore not compiled.

Maybe you can reedit the patch against 10.5 source

Sebastien

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added the missing dialogues to wxSmith.
« Reply #2 on: June 04, 2010, 08:43:23 pm »
 Hi Seb,

Yeah, thanks. I realised this a short while ago whilst generating the picker patch. I've regenerated it against SVN 6283.

It's getting increasingly tricky to isolate the changes for each patch. I also took the opportunity to add a bugfix, some minor improvements and the doxygen file tags. Apologies for the screw-up.

Cheers.


[attachment deleted by admin]