Author Topic: Added wxHyperlinkCtrl to wxSmith.  (Read 6365 times)

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Added wxHyperlinkCtrl to wxSmith.
« on: March 26, 2010, 01:44:53 am »

 Hi Guys,

I've added the wxHyperlinkCtrl control to wxSmith. I've been wanting to use this one from wxSmith for a long time.
All properties are available.
Tested in SVN 6190 on Win 7 on all GUI types.
Patch 2959 on Berlios.

Cheers,

  Cryo.


[attachment deleted by admin]

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #1 on: March 26, 2010, 04:00:04 am »
Sheesh. I didn't test well enough, apparently.  :?
Fixed bugs. New version attached.



[attachment deleted by admin]
« Last Edit: March 26, 2010, 04:35:59 am by Cryogen »

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #2 on: March 29, 2010, 07:53:28 am »
 :D Thanks! I'am waiting long time too.

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #3 on: March 29, 2010, 09:17:30 am »
Have a question, look the picture.
Why not use a small picture button?


[attachment deleted by admin]

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #4 on: March 30, 2010, 04:46:24 pm »

 Hi,

Have a question, look the picture.
Why not use a small picture button?


For some reason the patch hasn't installed them. The same happened to me on Linux last night. I have no idea why as they are listed in the patch. I've attached them. You just need to put them in src\devel\share\CodeBlocks\images\wxsmith.

Cheers.


[attachment deleted by admin]

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #5 on: March 30, 2010, 05:53:22 pm »

 Hi,

Have a question, look the picture.
Why not use a small picture button?


For some reason the patch hasn't installed them. The same happened to me on Linux last night. I have no idea why as they are listed in the patch. I've attached them. You just need to put them in src\devel\share\CodeBlocks\images\wxsmith.

Cheers.

un-work here, XPXP3.
When i add the png to share/...
But can not show the wxhyperlink png on wxsmith.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9415
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #6 on: March 30, 2010, 08:14:51 pm »
For some reason the patch hasn't installed them.
"patch" cannot handle binary content. You'll always have to provide binary files in addition.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #7 on: March 31, 2010, 05:59:29 pm »

 Hi,

Have a question, look the picture.
Why not use a small picture button?


For some reason the patch hasn't installed them. The same happened to me on Linux last night. I have no idea why as they are listed in the patch. I've attached them. You just need to put them in src\devel\share\CodeBlocks\images\wxsmith.

Cheers.

un-work here, XPXP3.
When i add the png to share/...
But can not show the wxhyperlink png on wxsmith.

Well, I assume you've run the update script afterwards or are using the version in "devel"? Otherwise put them in src\output\share\CodeBlocks\images\wxsmith, as well. You will need to restart, too.

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #8 on: March 31, 2010, 06:00:18 pm »
For some reason the patch hasn't installed them.
"patch" cannot handle binary content. You'll always have to provide binary files in addition.

Right, that would do it.  :)

Thanks, Morten.

Offline Loaden

  • Lives here!
  • ****
  • Posts: 1014
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #9 on: April 01, 2010, 12:37:26 pm »
I do not know where the mistake, but I restart the computer, it works very well! :lol:

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #10 on: April 07, 2010, 08:38:27 pm »

 Hi,

I do not know where the mistake, but I restart the computer, it works very well! :lol:

OK, that's good to know. Thanks.

Offline Cryogen

  • Regular
  • ***
  • Posts: 260
Re: Added wxHyperlinkCtrl to wxSmith.
« Reply #11 on: May 16, 2010, 05:09:00 am »

 Hi Guys,

I fixed a typo in the default label.

Cheers.


[attachment deleted by admin]