Author Topic: Starting the debuggee failed: No executable specified, use `target exec'.  (Read 1593 times)

Offline dboard514

  • Single posting newcomer
  • *
  • Posts: 2
Searching the web shows that this is not a new problem but I haven't found a solution that works for me. This is a new installation of codeblocks and I'm trying to get the debugger to work with a simple Hello World project. Likely I've configured something wrong. Debug window dump follows:

Active debugger config: GDB/CDB debugger:Default
Building to ensure sources are up-to-date
Selecting target:
Debug
Adding source dir: D:\C Sample Files\test_debug\
Adding source dir: D:\C Sample Files\test_debug\
Adding file: D:\C Sample Files\test_debug\bin\Debug\test_debug.exe
Changing directory to: "D:/C Sample Files/test_debug/."
Set variable: PATH=.;d:\Program Files\CodeBlocks\MinGW\bin;d:\Program Files\CodeBlocks\MinGW;C:\Program Files (x86)\Razer Chroma SDK\bin;C:\Program Files\Razer Chroma SDK\bin;C:\Program Files (x86)\Razer\ChromaBroadcast\bin;C:\Program Files\Razer\ChromaBroadcast\bin;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Windows\System32\config\systemprofile\AppData\Local\Microsoft\WindowsApps;C:\Program Files\dotnet;C:\Users\dboar\AppData\Local\Microsoft\WindowsApps
Starting debugger: D:\Program Files\CodeBlocks\MinGW\bin\gdb.exe -nx -fullname -quiet  -args "D:/C Sample Files/test_debug/bin/Debug/test_debug.exe"
done
Setting breakpoints
Debugger name and version: GNU gdb (GDB) 8.1
Starting the debuggee failed: No executable specified, use `target exec'.
Debugger finished with status 0

Any assistance is appreciated.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1584
Remove the spaces from the "C Sample Files" folder.

Offline dboard514

  • Single posting newcomer
  • *
  • Posts: 2
That solved it, thank you! I knew it was something simple I was missing.