Code::Blocks Forums

User forums => Help => Topic started by: Grifont on February 24, 2021, 07:52:39 am

Title: Can't find how to get out "permission denied"
Post by: Grifont on February 24, 2021, 07:52:39 am
Hello everybody !

I'm using Codebock 20.03 and I've got a problem. When I launch with "Start and build" it open and I can close it. But if I try to immediatly open it again with "Start and build" (or if a change something in the program) it gives me the error "Permission Denied". I looked for it on google and find out many solution. I tried everything but it isn't solve. I tried to :
- Desactivate my antivirus ;
- Uninstall/Reinstall Codeblock ;
- Uninstall/Reinstall Codeblock somewhere else than in the folder "Program files" ;
- Install Codeblock without compiler and install another to use it ;
- Desactivate all the protections that Windows puts on ;
- Put my projects in a folder on my desk.

Does anybody know how could I resolve that ? I need to use this program for my studies and I can't...

Thanks you !
Title: Re: Can't find how to get out "permission denied"
Post by: oBFusCATed on February 24, 2021, 08:21:19 am
Do you see the executable in task manager after you close it?
Title: Re: Can't find how to get out "permission denied"
Post by: gd_on on February 24, 2021, 10:00:40 am
For me, that's happen sometimes, especially when my program has crashed (because I introduced in it something wrong  :'()
I tried severall things, as using "Unlocker" software, deleting the .exe. Sometimes it works, sometimes it does not work ... "Unlocker" has the option to delete the .exe at next system restart : it works but it's not always convenient.
I find sometimes my .exe in one of the task manager window (but not the first one !), but generally can't stop it (no sufficient priviledges, even as administrator !)
Nevertheless, it's possible to rename my *.exe in something like *_locked.exe. I can't still delete it, but C::B can link again my executable.
Finally, a solution that works each time is to simply unconnect from your Windows account, and re-connect. Then you can work again, the "permission denied" is no more there ! And you are now able to delete your *_locked.exe ...