Code::Blocks Forums

Developer forums (C::B DEVELOPMENT STRICTLY!) => Contributions to C::B => Topic started by: LETARTARE on August 26, 2013, 01:58:35 pm

Title: Compile old svn ?
Post by: LETARTARE on August 26, 2013, 01:58:35 pm
I get r5382 to test a former plugin.
To compile I have to fill the global variable 'wx' and put the good compiler 'gcc'.
How to find the right values ?
link:
http://forums.codeblocks.org/index.php/topic,3299.msg26011.html#msg26011 (http://forums.codeblocks.org/index.php/topic,3299.msg26011.html#msg26011)
but it is insufficient.

Perhaps automatically remind, in remark, these elements in the project .cbp to adapt later ?

I do regularly on my projects and the 'Nightly Builds' in 'Properties-> Notes'.

Thank you for your help.
Title: Re: Compile old svn ?
Post by: eranon on August 26, 2013, 10:49:25 pm
Checking-out the r5382 and searching in all the .cpp and .h files for the "wxWidgets 2." string, I find several comments about wxWidgets, including this one in "configmanager-revision.cpp" :

Code
wxString ConfigManager::GetRevisionString()
{
// Code::Blocks needs wxWidgets 2.8
CompileTimeAssertion<wxMinimumVersion<2,8>::eval>::Assert();

    return autorevision::svnRevision;
}
Title: Re: Compile old svn ?
Post by: LETARTARE on August 26, 2013, 11:22:01 pm
@erabon
thanks for indications.
I had already done this kind of research, but the indications are very different since we found 2.4.x to 2.9.x
As the compiler ??

I wanted to point content was no indication in the project file (cbp) and it would be good to find a lasting solution.

Merci encore.
Title: Re: Compile old svn ?
Post by: eranon on August 26, 2013, 11:49:24 pm
The compiler is indicated in the cbp project file :

Code
<Option compiler="gcc" />

and in this same cbp file, you can read too :

Code
<Add library="wxmsw28$(WX_SUFFIX)" />
Title: Re: Compile old svn ?
Post by: LETARTARE on August 27, 2013, 12:09:54 am
yes,
- 'gcc' is very imprecise,  what version ?
- "wxmsw28$(WX_SUFFIX)"  to 2.8.0 to 2.8.12 ? unicode probably.
I want to indicate that a search request and successive tests, but after two failed compilation!!!
This could be avoided.

Title: Re: Compile old svn ?
Post by: stahta01 on August 27, 2013, 01:49:33 am
To get the wxWidgets version download the nightly that matches that svn version.

Do CB About, it will give you the wxWidgets version.

To determine, the mingw GCC version is very hard.

Verify the mingw.dll matches exactly and you might be correct.

Edit: Suggest reading the link http://wiki.codeblocks.org/index.php?title=Linking_the_plugin_to_a_Nightly_Build (http://wiki.codeblocks.org/index.php?title=Linking_the_plugin_to_a_Nightly_Build)

Tim S.
Title: Re: Compile old svn ?
Post by: jens on August 27, 2013, 06:18:33 am
You should get the gcc version on the StartHere-page.
At least the Major.Minor.Patch revision-number.
As far as I know it's always (sine a long time) TDM's gcc-version, but I do not know, whether it's dw2 or sjlj on windows.
Below the logo I have:
Quote
svn build rev 9266 (2013-08-17 14:07:34) gcc 4.8.1 Linux/unicode - 64 bit
on my laptop (Fedora 19 64-bit) when starting the actual build from my repo.
Title: Re: Compile old svn ?
Post by: LETARTARE on August 27, 2013, 04:15:44 pm
Thank you for your answers.

@stahta01
well, for 'wxWidgets it seems that 'wxWidgets-2.8.x' unicode, I will try 2.8.10 and 2.8.11 I still have disk...
'Mingw.dll' is not supplied with the svn source !

@jens
Quote
You should get the gcc version on the StartHere-page.
I only have sources and reading 'startherepage.cpp' I find nothing.

Reading the svn log:
Quote
5283 -> 23 october 2008 by byo
and by
http://forums.codeblocks.org/index.php/topic,3299.msg26011.html#msg26011 (http://forums.codeblocks.org/index.php/topic,3299.msg26011.html#msg26011)
->  'wxWidgets 2.8.9 (18 October 2008)' and 'MinGW-GCC 4.2.1'

To avoid these uncertain research do not we find a solution that would give this information?

I can not build with  'wxWidgets-2.8.11' and 'TDM-4.5.2' (at my disposal) !!

Thank you again