Recent Posts

Pages: [1] 2 3 4 5 6 ... 10
1
Using Code::Blocks / Re: CB 20.03 for windows, debug problems
« Last post by oBFusCATed on Today at 05:50:23 pm »
The uninstall/install cycle doesn't change anything in your settings.
You still don't have a clue where the problem was...
Just a note.
2
Plugins development / Re: Plugin integration for Code::Blocks 20.03
« Last post by ollydbg on Today at 04:41:09 pm »
If you build new plugins, I would suggest using the latest svn code, not the 20.03 release.
I don't know what the problem you have, please give use more details.
3
Using Code::Blocks / Re: CB 20.03 for windows, debug problems
« Last post by i386 on Today at 11:57:35 am »
I uninstall th CB 20.03. Then re-install it and setup the new gdb as above. After that I find all the debug process is OK.

These are the debug boot up log, the debugger stops at the breakpoint as expected:
---------------------
Active debugger config: GDB/CDB debugger:Default
Building to ensure sources are up-to-date
Selecting target:
Debug
Adding source dir: D:\cb\vulkan\
Adding source dir: D:\cb\vulkan\
Adding file: D:\cb\vulkan\bin\Debug\vulkan.exe
Changing directory to: D:/cb/vulkan/.
Set variable: PATH=.;C:\Program Files\CodeBlocks\MinGW\bin;C:\Program Files\CodeBlocks\MinGW;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0
Starting debugger: C:\Program Files\CodeBlocks\gdb-10.1.90.20201024-x86_64\bin\gdb.exe -nx -fullname -quiet  -args D:/devel/cb/vulkan/bin/Debug/vulkan.exe
done
Setting breakpoints
Debugger name and version: GNU gdb (ssbssa-1) 10.1.90.20201024-git
Child process PID: 8956
At D:\cb\vulkan\entry.cpp:30
4
Using Code::Blocks / Re: CB 20.03 for windows, debug problems
« Last post by oBFusCATed on Today at 10:14:31 am »
Post the full rebuild and debug logs.
5
Using Code::Blocks / Re: CB 20.03 for windows, debug problems
« Last post by i386 on Today at 03:31:15 am »
I download the 64bit version 'gdb-10.1.90.20201024-x86_64.7z', and extract to codeblocks installation directory. Setup the debugger as the link says.
Then setup a breakpiont and run Debugging...

Starting debugger: C:\Program Files\CodeBlocks\gdb-10.1.90.20201024-x86_64\bin\gdb.exe -nx -fullname -quiet  -args D:/devel/cb/vulkan/bin/Debug/vulkan.exe
done
Setting breakpoints
Debugger name and version: GNU gdb (ssbssa-1) 10.1.90.20201024-git
Child process PID: 9436
[Inferior 1 (process 9436) exited normally]
Debugger finished with status 0

----------->
The breakpoint was skipped, and the application 'vulkan' run to the end normally[judging from 'vulkan' app log]. The break point has no effect. I am sure the breakpoint is a VALID point. why?
7
Nightly builds / Re: The 03 January 2021 build (12286) is out.
« Last post by Khram on Yesterday at 03:26:59 pm »
The next version will be 12312.?
8
Using Code::Blocks / Re: CB 20.03 for windows, debug problems
« Last post by i386 on Yesterday at 01:50:20 pm »
I am sorry! The cannonical address form is OK. Because application runs in ring 3, the upper 16bits is always 0x0000H.

Now left questin 1.
9
Using Code::Blocks / Re: Font Ligatures Support
« Last post by Miguel Gimenez on April 09, 2021, 11:42:34 am »
That's a bug with text size calculation when using DirectWrite. I have it fixed on my system, but my patch was not accepted (and 20.03 was already launched anyway). See ticket 835 for more information.
10
Using Code::Blocks / Re: Font Ligatures Support
« Last post by geometric on April 09, 2021, 09:08:11 am »
However, I noticed that the autocomplete suggestions become very large. Is it cause by this setting or not?
Pages: [1] 2 3 4 5 6 ... 10