Code::Blocks Forums

User forums => Help => Topic started by: Hocki87 on November 11, 2020, 06:04:43 pm

Title: Grey rectangle appears instead of auto completion on MAC OS
Post by: Hocki87 on November 11, 2020, 06:04:43 pm
Hi guys,

I am doing lectures at the university teaching C++. We recommend using Codeblocks. However, three of my students using MAC OS mailed me, describing the following error.  I attached a PDF file that comprises a picture depicting to the appearance of the error. It gives the impression that instead of auto-completion only a grey box appears.

One student describes the problems as following:
I am currently using a laptop with the operating system macOS Catalania and have installed the program Codeblocks on YouTube using the following instructions.
As far as I can tell, this has worked (see picture 1 appendix). Creating a new project in Codeblocks and saving it in a separate folder worked the same way as your video (see picture 2+3 appendix).
Now I wanted to take the source code as in the video and encountered the following problem: after entering "#inc" for #include in the first line, a grey square pops up, which doesn't disappear again until you close the program. Further fluent typing is also no longer possible. Even after several restarts and retries, I could not fix the problem so far. 

He sends me a whole series of pictures. Unfortunately, due to the max_file_size I can only post one of the pictures.
I use Windows and am entirely at a loss. Any suggestions?
Title: Re: Grey boxes appear instead of auto complete on MAC OS
Post by: Miguel Gimenez on November 11, 2020, 06:13:19 pm
It is a known problem with Catalina, see (

Your students can disable Code Completion as a workaround.