Recent Posts

Pages: 1 2 [3] 4 5 6 7 8 ... 10
21
Help / Setting to prevent me debugging a Release build
« Last post by tigerbeard on June 15, 2024, 02:47:26 pm »
I thought i had seen a settings for this but I can not find it any more nor a forum post about it.

I happen to waste a lot of time recently by starting the debugger on a Release build by accident and realizing it too late (when no breakpoints work).

I would like CodeBlocks to prevent me doing that or give me a nagging dialog "Your build has no debug symbols set.Are you sure?"

Is there an option somehwere?

22
Nightly builds / Re: The 14 June 2024 build (13529) is out.
« Last post by Xaviou on June 15, 2024, 12:12:27 pm »
Hi.

OS X version of this rev can be downloaded from my website.
There is only a macOS-11.6 version.
Note that it is not a notarized version of the application.

32 bits version for Windows can also be can be downloaded from my website.

Debian Bookworm and Bullseye (32 and 64 bits) can be installed from my repo
The corresponding unsigned deb files can also be downloaded from the website page linked above.

Ubuntu-22.04, 23.10 and 24.04 versions can be installed from my ppa

Regards
Xav'
23
Nightly builds / The 14 June 2024 build (13529) is out.
« Last post by killerbot on June 14, 2024, 08:11:45 am »
We switched to gcc 14.1.0 (on 20 May 2024) --> download the new wx/mingw dll's see link below

Get the compiler we use here : https://github.com/brechtsanders/winlibs_mingw/releases/download/14.1.0posix-18.1.5-11.0.1-ucrt-r1/winlibs-x86_64-posix-seh-gcc-14.1.0-mingw-w64ucrt-11.0.1-r1.7z

Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll(s) for Code::Blocks : https://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/wxmsw32u_gcc_cb_wx325_2D_gcc1410-mingw64.7z
A link to Mingw64 dll's needed by Code::Blocks : http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/Prerequisites/Mingw64dlls14.1.0.7z


The 14 June 2024 build is out.
  - Windows :
   http://sourceforge.net/projects/codeblocks/files/Binaries/Nightlies/2024/CB_20240614_rev13529_win64.7z
  - Linux :
   none

The current SDK version is : 2.25.0

Resolved Fixed:

  • lib_finder: Fix stack corruption when clicking on "Try to detect missing ones".
  • BrowseTracker 1.4.116 24/06/1 Allow user to set max entries for jump,browse marks etc.

Regressions/Confirmed/Annoying/Common bugs:


    24
    Embedded development / Re: error: -mmcu
    « Last post by Miguel Gimenez on June 13, 2024, 11:49:47 am »
    Follow the link I gave you in reply #3 and post a full rebuild log (use code tags, please).
    25
    Embedded development / Re: error: -mmcu
    « Last post by Nayani on June 13, 2024, 11:41:07 am »
    HI Miguel Gimenez,
    I tried command line and the build (only compile) seems to have gone through without a hitch. Here is what I typed

    msp430-elf-gcc -c -IC:\ti\msp430-gcc\include -mmcu=msp430f67791 main.c   

    The main.c file content, copied from the NET

    #include "msp430f67791.h"
    //#include <msp430.h>            

    int main(void) {
       WDTCTL = WDTPW | WDTHOLD;      // Stop watchdog timer
       P1DIR |= 0x01;               // Set P1.0 to output direction

       for(;;) {
          volatile unsigned int i;   // volatile to prevent optimization

          P1OUT ^= 0x01;            // Toggle P1.0 using exclusive-OR

          i = 10000;               // SW Delay
          do i--;
          while(i != 0);
       }
       
       return 0;
    }

    The issue is to configure code::blocks properly!!!! Not getting it.

    26
    Nightly builds / Re: The 28 January 2024 build (13434) is out.
    « Last post by SharkCZ on June 12, 2024, 10:52:48 pm »
    I have just pushed the latest nightly as an update to Fedora 40 (see https://bodhi.fedoraproject.org/updates/FEDORA-2024-106b2196b0). Most of the nightly builds is available from https://copr.fedorainfracloud.org/coprs/sharkcz/danny/ after they are announced.
    27
    Embedded development / Re: error: -mmcu
    « Last post by Nayani on June 12, 2024, 01:19:34 pm »
    Thank you. I did tick (selected the controller from the available list) however the compiler complains about "mmcu" not being set. This is the issue. I will try the command line and update you.

    RGDS
    NPS
    28
    Embedded development / Re: error: -mmcu
    « Last post by Miguel Gimenez on June 12, 2024, 01:03:05 pm »
    Using the specific compiler is the way relevant options are supported, so you do not need to add other compiler options.
    Ticking the MCU will generate the "-mmcu=" flag, enable full build log and check.
    29
    Embedded development / Re: error: -mmcu
    « Last post by Nayani on June 12, 2024, 12:41:33 pm »
    Hi Miguel Gimenez,
    Thank you very much for your reply. Just wanted to clarify
    1. Is it necessary to use "GNU GCC Compiler for MSP430 (HighTec)" compiler only? As mentioned earlier I have msp430-gcc compiler and I included a sample header file, which gave no errors. MSP430GCC has support for my controller.
    2. In case the CPU is listed, by selecting (ticking), "-mmcu=" flag should have been generated/added. Am I right? Or is it necessary that I add this under "other compiler options"?

    I await your reply. Thanks once again.
    Regards
    NPS
    30
    Embedded development / Re: error: -mmcu
    « Last post by Miguel Gimenez on June 12, 2024, 11:10:22 am »
    You should use the "GNU GCC Compiler for MSP430 (HighTec)". If your CPU is not listed, but suported by the compiler, you can add it in the "Other compiler options", p.e. -mmcu=mps430xG666
    Pages: 1 2 [3] 4 5 6 7 8 ... 10