Code::Blocks Forums

User forums => Help => Topic started by: *Armageddon on July 11, 2010, 09:00:23 pm

Title: Plz help a n00b out
Post by: *Armageddon on July 11, 2010, 09:00:23 pm
Hello.
Im just starting to learn C++, and ive been getting:
SayHello - Debug" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...
Nothing to be done

im using Microsoft XP, with Code::Blocks v8.02

but i know what you're thinking, that i need to search the forums, that its asked three times a week, i know. i also know the problem is that i haven't installed the GNU GCC compiler.

My real question here is, where can i safely download the compiler?
Title: Re: Plz help a n00b out
Post by: seb_seb0 on July 11, 2010, 09:11:16 pm
Hello,

this is the wrong place to ask.
However, here is a link:
http://tdm-gcc.tdragon.net/download (http://tdm-gcc.tdragon.net/download)

Download the "Bundle Installer" 32 bits.

Or type "MinGW download" on google : there are plenty of alternatives

2nd, download the last version of Code::Blocks, I do not understand why you are still using version 8.02 when version 10.05 is released.

Best regards,

Sebastien
Title: Re: Plz help a n00b out
Post by: *Armageddon on July 11, 2010, 09:15:56 pm
thank you help, i appreciate it.
i also apologize for the incorrect placement of my question.
to answer your question, im still using v8.02 because im learning from C++ for dummies, and they use v8.02. until i become acquainted with c++, i will update to v10.05. If you see no reason to wait, please let me know 
Title: Re: Plz help a n00b out
Post by: jens on July 11, 2010, 09:25:15 pm
As first: I suggest using C::B  10.05 instead of 8.02,
as second: just download the package with MinGW included, after installing you might have to make sure the compilers master path ("Setup -> Compiler and debugger... -> Global compiler settings -> GCC -> Toolchain executables") points to MinGW's base directory.
Title: Re: Plz help a n00b out
Post by: *Armageddon on July 11, 2010, 09:29:14 pm
Thank you both very much :)

As for the version, im still a little hesitant. is 10.05 vastly different and/or superior?

i know next to nothing about C++, and im a little hesitant to stray from the book until i know what im doing.

<side note: where should this question have been placed?>
Title: Re: Plz help a n00b out
Post by: Folco on July 12, 2010, 02:23:48 am
As for the version, im still a little hesitant. is 10.05 vastly different and/or superior?
Yes. It adds a lot of improvements to the editor, and if you're learning C++, you shouldn't have any problem. C::B is the source code editor, not the compiler nor the linker. And even old examples will be compatible. Don't worry, use the new C::B and its conveniences. :)