Recent Posts

Pages: 1 [2] 3 4 5 6 7 ... 10
11
Before or after editing the cbp file with a text editor?
I suppose the Compiler Flags tab doesn't have a "-Wall" option.
Keep in mind that these compilers are rarely used in codeblocks, so they might be outdated.
Also keep in mind that last time (12+ years ago) I've tried D in C::B the dependency tracking didn't work well/at all, so you might need to do full rebuilds every time you change something major.
12
This can be edited in the GUI using Project -> Build options -> [target or project] -> Compiler settings -> Other compiler settings

Thanks for the reply.  I looked at that tab, but it was blank/empty.
13
This can be edited in the GUI using Project -> Build options -> [target or project] -> Compiler settings -> Other compiler settings
14
You can look also in Settings -> Compiler

Thanks for the reply. If I go there it gives me the settings which only apply to the DMD Windows compiler and there is no -Wall option and the "Other compiler options" tab is blank.

I notice that my "cbp" file was not updated when I changed the compiler in Code::Blocks. That file still thinks I am using gdc and has the -Wall option in it:

      <Compiler>
         <Add option="-Wall" />
      </Compiler>

 And yet doing a build invokes the DMD compiler??

But apparently it is ignoring that file as when I removed -Wall from it and set the correct compiler it still invokes DMD with the -Wall option.

I got out of Code::Blocks and back in and it still wants to add -Wall to a command line that is invoking DMD, which does not support that option.
------------------------------------------
I relooked at the cbp file and while I thought I had removed the -Wall option, it was still there. I removed it (again?) and then I was able to get a successful compile.
15
I just forgot where I can create the tickets as before.
regards.
16
Please log an issue on https://sourceforge.net/p/codeblocks/tickets/
Here it will be forgotten.
17
You can look also in Settings -> Compiler
18
I installed Code:Blocks for Windows and it detected the gcc C compiler and Digital Mars D compilers on my system. But when I created a D program and went to compile it Code::Blocks had set the GNU D compiler (GDC) as the compiler to use. That is not on my system and it failed. So I went and changed the compiler for the project to the DMD compiler. However, trying to compile with the Digital Mars compiler fails because Code::Blocks is putting a compiler option of -Wall which DMD does not support. I cannot see that setting in the Project->Build Options->Compiler Settings so I don't know how to get rid of it.
19
> "no target" in "no project"

Building without a Code::Blocks project can be unhealthy indeed...
20
recent head version, svn12458
Just take codeblocks project as the example will re-show the issue.
Im not sure if it same for windows version.
Pages: 1 [2] 3 4 5 6 7 ... 10