Code::Blocks Forums

User forums => Using Code::Blocks => Topic started by: AleX_XelA on March 27, 2012, 12:53:00 pm

Title: Cannot build project with FMOD after pressing "Rebuild"
Post by: AleX_XelA on March 27, 2012, 12:53:00 pm
Hello everyone,

I have been using Code::Blocks for the past few weeks, and everything has been working like a charm until yesterday. For some unknown reason, I tried using the "Rebuild" button, which I had never used before. Sadly, ever since I pressed that button, I can't compile any project using FMOD anymore...
Here is the message the IDE outputs :

And here is the source code (there are only the basics here) :
#include <stdio.h>
#include <stdlib.h>
#include <fmodex/fmod.h>

int main()
    FMOD_SYSTEM *system=NULL;
    FMOD_System_Init(system, 2, FMOD_INIT_NORMAL, NULL);

    FMOD_System_CreateSound(system, "SFX/son.wav", FMOD_CREATESAMPLE, NULL, &son);
    FMOD_System_PlaySound(system, FMOD_CHANNEL_FREE, sout, 0, NULL);


    printf("FMOD fonctionne !\n");
    return 0;

There is no RPT file generated by CB. I have tried to compile projects using other libraries and they work well.

I have properly linked the library with the project, and the runtime DLL is in the project's folder. Once again, the project compiled perfectly well until I decided to press the "Rebuild" button.

I am using the latest Code::Blocks available in the Downloads page, provided with the mingw compiler. I am using the GCC compiler. I  have tried re-installing Code::Blocks but that did not work. I have also set-up a fresh FMOD install, no luck there either. I downloaded the latest version of FMOD available here (

Thanks in advance,

Title: Re: Cannot build project with FMOD after pressing "Rebuild"
Post by: stahta01 on March 27, 2012, 02:52:10 pm
This is very likely a Compiler or Library problem.

You most likely did a typo in a header file by accident or have an macro declared wrong. (

I suggest turning on Full Compiler Logging and asking your question on a site that supports your Compiler and/or Library!

Reinstalling Compiler and/or library might fix the issue.

NOTE: Re-installing Code::Blocks does NOT re-install any Compiler or erase Code::Blocks configuration.

Tim S.