Recent Posts

Pages: 1 2 3 4 [5] 6 7 8 9 10
Using Code::Blocks / Only terminal window came out when I try to run
« Last post by ayyitsrach on November 28, 2023, 08:20:09 pm »
Hello, I am quite new in using CB and is facing a problem where when I try to run my code, the output did not appear. Only the black terminal window.

I am using CB 20.03 MinGw and in Windows 11.

Before, all my projects can run smoothly until now, suddenly. I've tried running my previous project, no output came out. Tried running outside IDE, from the bin folder, nothing came out. I'm not sure if I clicked something while working on my current project.

I've tried uninstall and re-install back CB but nothing changes.

I've disabled my Antivirus, nothing changes.

Build logs:

-------------- Build: Debug in trying (compiler: GNU GCC Compiler)---------------

Target is up to date.
Nothing to be done (all items are up-to-date).

-------------- Run: Debug in trying (compiler: GNU GCC Compiler)---------------

Checking for existence: C:\Users\User\Desktop\trying\bin\Debug\trying.exe
Set variable: PATH=.;C:\Program Files\CodeBlocks\MinGW\x86_64-w64-mingw32\lib;C:\Program Files\CodeBlocks\MinGW\bin;C:\Program Files\CodeBlocks\MinGW;C:\Program Files\CodeBlocks\MinGW\bin\bin;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Users\User\AppData\Local\Microsoft\WindowsApps;C:\Users\User\AppData\Local\Programs\Microsoft VS Code\bin
Executing: "C:\Program Files\CodeBlocks/cb_console_runner.exe" "C:\Users\User\Desktop\trying\bin\Debug\trying.exe"  (in C:\Program Files\CodeBlocks\MinGW\x86_64-w64-mingw32\bin)
Process terminated with status -1073741510 (0 minute(s), 5 second(s))
I hope I have given enough information for my problem.
General (but related to Code::Blocks) / Re: Welcome Newcomers - PLEASE READ!!!
« Last post by ayyitsrach on November 28, 2023, 08:05:13 pm »
I am new and I am here trying to learn. Hope we can learn things together
Just to let you know Tim, that is for C++, which I am not currently studying at the moment ..... I am trying to study C only.... if you could find me a similar tutorial like this but for C, I would be very grateful.....

Otherwise, thank you anyway :)
Thank you Tim, will read that now. Cheers!!  :)
Link to how to create a project in CB

FYI: Using spaces in filenames is a good way to make sure you are likely to spend hours trying to fix build issues.

Tim S.
Hold on, I went down to the bottom, near all the tabs (such as 'Cccc', 'Build log' 'Build messages' etc.) and got this:

-------------- Build file: "no target" in "no project" (compiler: unknown)---------------

gcc.exe   -c "C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.c" -o "C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.o"
gcc.exe  -o "C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.exe" "C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.o"   
Process terminated with status 0 (0 minute(s), 1 second(s))
0 error(s), 0 warning(s) (0 minute(s), 1 second(s))
Checking for existence: C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.exe
Executing: '"C:\Program Files\CodeBlocks/cb_console_runner.exe" "C:\Users\cathe\Documents\Not Onedrive C file GIRAFFE ultimateee.exe"' (in 'C:\Users\cathe\Documents')
Set variable: PATH=C:\Program Files\CodeBlocks\MinGW\bin;C:\Program Files\CodeBlocks\MinGW;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files\dotnet;C:\Users\cathe\AppData\Local\Microsoft\WindowsApps
Process terminated with status -1073741510 (0 minute(s), 11 second(s))
'Rebuild' is greyed out... it won't let me click on it...
Stop posting images and read carefully the link I gave you. You have not posted the full rebuild log I asked for.

go to Settings->Compiler and debugger...->Build options (tab) and check Save build log and Always output the full command line)

Then click on "Rebuild" (near the "Build and run" button) and paste the build log here using code tags (the # in the forum editor).
Update: I have of course, worked out how to not save to OneDrive. I shouldve known this originally, seeing as I have been working with computers extensively for about 26 years now. Oops. Anyway here is the file path now (see picture please).
Excuse the fact the files are called 'GIRAFFE' etc. by the way, this was me copying a YouTube video which used Giraffe as the file name. TIA.
Pages: 1 2 3 4 [5] 6 7 8 9 10