Code::Blocks Forums

Developer forums (C::B DEVELOPMENT STRICTLY!) => Development => CodeCompletion redesign => Topic started by: ollydbg on April 16, 2013, 07:24:40 am

Title: RFA: variable name chanage in CC
Post by: ollydbg on April 16, 2013, 07:24:40 am
A lot of variable/function I believe need to be changed for more readability.

ParserThreadedTask: what does "Threaded" mean? I don't know, so a more meaningful is needed, the same as MarkFileAsLocalThreadedTask.

ccSearchData: generally I don't like the "data" word, it does not have much information, maybe a better name is Cursor or Location.

m_Str: mainly I think it is a string stack in Shift-reduce parser (, "Str" does not have much meanings

There is much more, but let's firstly discuss above ones.  ;)