Author Topic: Dependency problems with svn 5269 on debian ?  (Read 2205 times)

Offline mess-mate

  • Multiple posting newcomer
  • *
  • Posts: 16
Dependency problems with svn 5269 on debian ?
« on: October 14, 2008, 12:00:20 pm »
Hi,
i would just yet update C::B to svn 5269 but can't because there are dependency problems.
codeblocs want codeblocs-common so far ok,  after saying ok, i've following message:

codeblocks:
  Depends: libcodeblocks0 (=1.0svn5269) but 8.02 is to be installed
 Recommends: codeblocks-contrib but it is not going to be installed

and stop of course.
mess-mate
regards
mess-mate (Linux/Debian)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Dependency problems with svn 5269 on debian ?
« Reply #1 on: October 14, 2008, 12:13:14 pm »
Version number 8.02 is higher then "1.0svn...".
You can force the "downgrade". How to do this depends on your package manager.

The easiest way is to uninstall 8.02, and install the svn-version afterwards.

The config-files will not be removed.
To be sure, that nothing get lost, I stricly recommend to backup the "~/.codeblocks"-folder ("cp -r ~/.codeblocks ~/codeblocks.save").

Offline mess-mate

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: Dependency problems with svn 5269 on debian ?
« Reply #2 on: October 14, 2008, 01:20:36 pm »
Thanks, my faute, there stay left a libcodeblocks who's not automatically removed..
Don't know she's there  :oops:
libwxsmithlib0-dev is installed and locked, why ? ( synaptic )

BR
« Last Edit: October 14, 2008, 01:46:38 pm by mess-mate »
regards
mess-mate (Linux/Debian)