Author Topic: Bug with the Print functionality  (Read 5413 times)

Zlika

  • Guest
Bug with the Print functionality
« on: September 08, 2005, 10:29:26 pm »
I have submited this bug in the "Sourceforge Trackers" but it don't seem to be very used.
So I write it here to:
The information entered in the "Print setup dialog" are
not used during the printing.
The result is, for example, you can't print on another
printer than the defaut printer.

I think I have located the bug in cdeditor.cpp, function
void cbEditor::Print(bool selectionOnly, PrintColorMode
pcm), line 1033 (on the v1R1-1 code).

The line:
wxPrinter printer;

should be (I think):
wxPrinter printer(g_printData);

Zlika

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Bug with the Print functionality
« Reply #1 on: September 08, 2005, 10:43:42 pm »
The trackers are very important - just because a bug isn't fixed right away doesn't mean we don't pay attention to it.

We use the trackers to track (doh :P ) the bugs that we need to fix, i.e. we have fixed N bugs, 30 to go. Bugs with high priority are attended first, depending on the severity of the bug. Also, we receive the bugs reported there by mail. Sometimes we have to stop fixing some "non-critical bugs" if we're planning to release a new version (like right now), so don't get desperate. Having a bug in the tracker ensures that it'll be fixed - sooner or later.

In contrast, the forums are very difficult to track, and the database could be deleted due to some failure or something. In any case, thanks for submitting.

bal06

  • Guest
Re: Bug with the Print functionality
« Reply #2 on: September 19, 2010, 03:23:39 am »
Hi,
I am facing the still existing issue  under Ubuntu 10.04 :
"The result is, for example, you can't print on another printer than the defaut printer." :(
with CB 10.05.
Then I cannot print because I do not use a Postscript one.

Any Idea ?

Thanks