Author Topic: strange browsetracker bug?  (Read 2493 times)

Offline r.stiltskin

  • Multiple posting newcomer
  • *
  • Posts: 48
strange browsetracker bug?
« on: May 12, 2008, 04:02:30 am »
I checked "enable browsemarks" in the editor settings, and now I find that if my cursor is in a Firefox window and I click on an open editor window to switch back to code::blocks, it sets a browse mark.

It is happening often, but not *every* time (for example, it doesn't happen from this "start new topic" input window, but it does happen if I click on the border of this window and then in codeblocks editor), and I can't figure out the exact sequence that causes it.  I'm using Firefox 2.0.0.14 in Kubuntu gutsy, with c::b nightly 5046.  Can anybody else confirm this behavior?

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2319
Re: strange browsetracker bug?
« Reply #1 on: May 12, 2008, 05:12:56 am »
Try raising the delay time for a browseMark in the settings dialog.
Or try using Ctrl-mouse as the browseMark key.

I'm interested in your results of this trial.

It would also be helpful to know what your current settings are.


Offline r.stiltskin

  • Multiple posting newcomer
  • *
  • Posts: 48
Re: strange browsetracker bug?
« Reply #2 on: May 12, 2008, 05:59:13 am »
After setting Left_Mouse Toggle Delay=400 ms (instead of original value of 200) the problem went away.

Then I set it back to 200 ms and set the Toggle BrowseMark Key to Ctrl-Left_mouse, and behavior was OK.

Then I set it back to the original settings (delay=200 ms and Toggle Key=Left_mouse) to see if I'm hallucinating, and again got the unwanted BrowseMarks.

I will use Ctrl-mouse as the toggle key -- that solves the problem and actually seems more convenient anyway.