User forums > Help

Issue with VC++ compiler options

(1/3) > >>

wiz:
Hi, everyone. My situation is as follows: I'm trying to build the Yake engine using CodeBlocks RC1-1 and Microsoft Visual C++ Toolkit. I imported a .vcproj file inside CB and everything seems to work fine; but, when I begin the compilation, I receive the following message for each source file:

cl : Command line warning D4025 : overriding '/MDd' with '/MT'

This message is related with the debug settings.

In order to compile the engine correctly, I must remove the '/MT' option from the compiler, but I can't find a way of doing it! Does anyone know a way of achieving it?

Thanks in advance!  :D
Edgard

Vampyre_Dark:
Woudln't this be in the build options? Right click on the project, and select Build Options. There is a panel of boxes you can toggle, and then another tab with extra typed in commands. Should be in there.

wiz:
No, this isn't, I already looked up all of the options. The '/MT' option is set under the hood, and I can't find a way to access it...  :(

rickg22:
Are you sure that's NOT a linker message? (You know Microsoft tools, they do whatever they please)

tiwag:
"/MT" is selected with the Multi-threaded Runtime Library
"/MTd" is selected with the Multi-threaded Debug Runtime Library

select only one of the runtime options


[attachment deleted by admin]

Navigation

[0] Message Index

[#] Next page

Go to full version