Author Topic: Can CodeBlocks run with wxGTK-devel installed on suse?  (Read 4621 times)

Offline kaduflyer

  • Single posting newcomer
  • *
  • Posts: 2
Can CodeBlocks run with wxGTK-devel installed on suse?
« on: January 18, 2011, 10:11:29 pm »
I've downloaded and installed codeblocks-10.05-0-suse112.i686.rpm on suse. I also installed wxGTK-devel version 2.8.10.1-11.2 which is the only package I see for wxWidgets. When I try and run CodeBlocks, I get this error:

codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

I'm very new to Linux, so any help is appreciated.

Offline pirx67

  • Multiple posting newcomer
  • *
  • Posts: 35
Re: Can CodeBlocks run with wxGTK-devel installed on suse?
« Reply #1 on: January 18, 2011, 10:53:05 pm »
Hi,

you could search the Code::Blocks forums with
Quote
"relocation error" libcodeblocks
to get a lot of posts related to the same or similar problems.

One of it that may fit is http://forums.codeblocks.org/index.php/topic,13187.0.html.

Hope that helps,
   pirx67

Offline kaduflyer

  • Single posting newcomer
  • *
  • Posts: 2
Re: Can CodeBlocks run with wxGTK-devel installed on suse?
« Reply #2 on: January 19, 2011, 05:34:56 pm »
Since the concensus seems to be that openSuse provides wxWidgets libs that aren't compatible with CodeBlocks, I uninstalled those libs, went to the wxWidgets web site and downloaded wxWidgets-2.8.11.tar.gz, and installed those on openSuse.

End result is same relocation error.

Looks like CodeBlocks and/or wxWidgets is broken on openSuse.

Offline pirx67

  • Multiple posting newcomer
  • *
  • Posts: 35
Re: Can CodeBlocks run with wxGTK-devel installed on suse?
« Reply #3 on: January 21, 2011, 08:25:15 am »
Hi,

I'm not very familiar with OpenSuSE these days (I'm using Ubuntu) but a little more googling around revealed this OpenSuSE forum post that shows at least a solution for OpenSuSE 11.3.

The keywords for google were:
Quote
codeblocks vxwidgets solution "link time reference" opensuse

This was one of the results:

http://forums.opensuse.org/english/get-technical-help-here/applications/447515-code-blocks-not-starting.html

Maybe this will help you also ...

Greets.