Author Topic: uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...  (Read 44241 times)

xiaotian_ls

  • Guest
Hi:
I encounter a problem today, When I create a project and try to build it, there is a message appearred on build log console:"test1 - Debug uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...", and nothing response next.
How to reslove it?
Anyone knows it help me please.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9613
I encounter a problem today, When I create a project and try to build it, there is a message appearred on build log console:"test1 - Debug uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...", and nothing response next.
It means the compiler setup for this projct cannot be found. Check the compiler settings -> path and names of executables under toolchain executables of this specific compiler.
It can oalso mean someone provided you with a project (file) that uses a manually compiler setup (e.g. a copy of an existing compiler) and he didn't provide you this information.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

tornawida

  • Guest
Thank you for your answer it really helped me.
At last I managed to install MinGW, wxWidgets and Code::Blocks
(with the manuals and answers like this ofcourse)
The last thing left is installing and configuring wxFormBuilder
wis me luck ... :D

CodeBlogger

  • Guest
I encountered the same problem and solved it after a bit of tinkering...
steps would be:
1. goto "Menu"->Settings ->"Compiler and Debugger" -> [It will open a new Tab ]..... ->
2. In this tab, you have listings like...Compiler flags, Linker settings, Search subdirectories,......  next to that is ">" button, click on the ">" button 2-3 times, till you find "Toolchain executables" in same line.
3. In this window, set "compiler settings" to which ever directories your compiler is installed.
4. For varification, goto lower section of tab-menu and click on location button for gcc or g++, it shoulddirectly open a new browser window and gcc /g++ is selected.
   <If this is done, your code::blocks should be working>


jamesB

  • Guest
I had the same thing happen on a new install of Code::Blocks 8.02.  The aforementioned compiler settings for Toolchain executables all appeared to have the correct path for mingw32-g*, but it didn't start compiling until I clicked the Auto-detect button on this tab.

Maxfield

  • Guest
THANK YOU CodeBlogger.  I have been trying to find a solution to that problem for a while now and that was it!