Author Topic: CB can't find Header included in an Header  (Read 2359 times)


  • Guest
CB can't find Header included in an Header
« on: August 23, 2007, 06:42:03 pm »
I tried to compile an Ogre3D Project with CB and I tried to compile the CB Plugins from SVN, both give me the same error.

CB can't find the Header Files which are included in another Header File.
I'm not that experienced with C++ and not sure if it is an CB related problem or if there are mistakes in the Code, so here is an example.

C:\OgreSDK\include is in my search path

in C:\OgreSDK\samples\example.cpp there is OIS.h included:
#include <OIS\OIS.h>

No Problem this far, but in OIS.h there are some Headers included like:
#include "OISmouse.h"

CB can't find those files, but all the OIS Headers are in the same directory.
I thought CB should look for these files in the same directory like the file where it was included?

I got the same problem when I wanted to compile CB from source, CB itself compiled fine, but when I tried to compile the Plugins CB can't find the needed Headers.

I'm running CB under Windows XP and  wx2.4.8.0 with MinGW.