Author Topic: Some Toolbar images are still not grayed out corectly!!  (Read 2411 times)

Offline Szabadember

  • Multiple posting newcomer
  • *
  • Posts: 75
  • That's me!
Some Toolbar images are still not grayed out corectly!!
« on: January 27, 2007, 02:15:54 pm »
Hi!
The pull-down menus are working great, some bugs related to the toolbar were also fixed, but the save button still won't gray out correctly and if i use big icons(24*24) some other icons do not gray out too (cut,copy,paste).
What about these icons?  :shock:

i'm using your patched wxWidgets dll ,Win XP SP2, rev3542

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7180
    • My Best Post
Re: Some Toolbar images are still not grayed out corectly!!
« Reply #1 on: January 30, 2007, 01:32:12 pm »

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • menu items with icon not correctly aligned (since wx263) (is fixed with our special wx263/wx28 dll)


I consider that the toolbar-images-not-changing-state Confirmed bug, I looked at it and I see nothing wrong so someone who knows wxWidgets and Code::Blocks better that me may see the cause. It still exists with wxWidgets 2.8 branch cvs code. My fix for the menu items not changing state and menu items with icon not correctly aligned were just back ports of fixes from wxWidgets 2.8.1+ from cvs. I am a newbie to wxWidgets and Code::Blocks ( about 6 months experience with each).
Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org