Author Topic: Codecompletion doesn't parse  (Read 3495 times)

Offline raph

  • Almost regular
  • **
  • Posts: 242
Codecompletion doesn't parse
« on: January 22, 2007, 07:42:36 pm »
Hi,

I'm currently trying to get code completion to work properly :D
It somehow doesn't scan "external" include files automaticly, so it only knows types and vars from my project.
Anyway, I managed to fix this, by deactivating c++ parsing and reactivating it ("Follow LOCAL includes", "Follow GLOBAL includes", "Parse preprocessor directives").
I'm then asked whether I want to reparse my projects with the new options and it works perfect until codeblocks is closed and restarted.

Is this a known issue?
How can I make cc to reparse my projects, easilier?

I'm using WinXP with the latest nightly build (svn 3526)

Thanks for help
raph

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: Codecompletion doesn't parse
« Reply #1 on: January 23, 2007, 11:08:24 am »
Is there any way to e.g. bind reparsing to a shortcut?

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9614
Re: Codecompletion doesn't parse
« Reply #2 on: January 23, 2007, 02:56:23 pm »
Is there any way to e.g. bind reparsing to a shortcut?
Goto the symbols browser, right-click on "Symbols" and select "Re-parse now".

BTW: The effect you have described earlier is unfortunately not reproducible to me. Any additional information? A step-by-step guide? A project that demonstrates this issue?

With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: Codecompletion doesn't parse
« Reply #3 on: January 23, 2007, 03:37:02 pm »
I switched to the latest nightly build (22. January) and reinstalled mingw (using the installer this time and not downloading and extracting the files manually) and it seems to work, now  :shock:  :D
To bad I can't reproduce the problem :(

Thx for your help
raph

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: Codecompletion doesn't parse
« Reply #4 on: January 23, 2007, 08:10:53 pm »
It was probably a bug in wxSmith ( :shock: ), easy to fix. We can forget about it now ;)