User forums > Using Code::Blocks

[SOLVED] Linking error


David Perfors:
I am trying to compile CodeBlocks on Linux and everything is going fine, until the process wants to link devel/codeblocks.exe (Note the exe, shouldn't that be changed?)
I get the following error:

--- Code: ---Linking executable devel/codeblocks.exe...
/usr/local/lib/ undefined reference to `_gtk_accel_group_detach'
/usr/local/lib/ undefined reference to `_gtk_accel_group_attach'
/usr/local/lib/ undefined reference to `_gtk_rc_context_get_default_font_name'
collect2: ld returned 1 exit status
make: *** [devel/codeblocks.exe] Error 1
--- End code ---

I am using wxWindows 2.4.2 with gtk+2 support (because I wanted to add unicode support), the latest cvs version of C::B (updated 1 july 2005 just half an hour before posting)

Any ideas?

It seems to me that someone has not read the wiki    ;)

David Perfors:
hehe, I thought I did that, but that was when I compiled a unicode version :oops:


It worked, Compiling plugins now... :lol:


[0] Message Index

Go to full version