Author Topic: SubVersion code checked out... so now what?  (Read 4284 times)

helgihg

  • Guest
SubVersion code checked out... so now what?
« on: December 08, 2006, 04:40:11 pm »
Hi.

I must admit I barely know anything about Autoconf and co, but I've downloaded the most recent SubVersion version of Code::Blocks and I'm unable to compile it. I'm used to there being an "autogen.sh" file or something of the sort that does all the magic when downloading from CVS repositories, but there's no such thing with Code::Blocks. I tried 'bootstrap', and that seemed to create a couple of familiar files, but none of them seem to actually do anything that makes sense. Long story short; "how do I build Code::Blocks from SubVersion?"

Now, with all due respect, I really don't feel like learning every in and out about Autoconf and frankly I'll rather stick to XTerm/gVim. There must be a series of lines that I can write to get this whole thing going, I mean... that's why people use Autoconf to begin with, right? :) I'm sure everyone knows the feeling that they don't know how to fix something and all the help that is provided is "why do you want to do that?" or "RTFM", which by definition are not help, and I'm looking for help, not someone to tell me how their world view works. That said, thanks in advance.

Debian Linux, kernel 2.6.17, wxWidgets installed (and I use it heavily myself so I know it works), GTK version.

Some output if that helps:

[helgihg@nixon ~/SubVersion/codeblocks]$ ./bootstrap
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
aclocal: configure.in: 75: macro `AM_OPTIONS_WXCONFIG' not found in library
aclocal: configure.in: 76: macro `AM_PATH_WXCONFIG' not found in library

[helgihg@nixon ~/SubVersion/codeblocks]$ ./configure
configure: error: cannot find install-sh or install.sh in "." "./.." "./../.."


Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2315
Re: SubVersion code checked out... so now what?
« Reply #1 on: December 08, 2006, 05:52:37 pm »
   //-- Wiki Index
       CodeBlocks Wiki Index
   //-- Wiki Main Page
    CodeBlocks Wiki Main Page

Search the wiki index for "Building"


Offline Marenz

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: SubVersion code checked out... so now what?
« Reply #2 on: January 15, 2007, 01:54:14 pm »
s.o. may add this to the Building-FAQ

On debian you need the package  wxwin2.4-headers if you get the errormessage

aclocal: configure.in: 75: macro `AM_OPTIONS_WXCONFIG' not found in library
aclocal: configure.in: 76: macro `AM_PATH_WXCONFIG' not found in library

--Ano

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: SubVersion code checked out... so now what?
« Reply #3 on: January 15, 2007, 01:59:24 pm »
s.o. may add this to the Building-FAQ

On debian you need the package  wxwin2.4-headers if you get the errormessage

aclocal: configure.in: 75: macro `AM_OPTIONS_WXCONFIG' not found in library
aclocal: configure.in: 76: macro `AM_PATH_WXCONFIG' not found in library

--Ano


wx2.4 is not supported for building C::B...
Be patient!
This bug will be fixed soon...

Offline Marenz

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: SubVersion code checked out... so now what?
« Reply #4 on: January 15, 2007, 02:50:09 pm »
uh?
I could not build the svn till i have installed this package.. i got hte same error as the one who started the post..
and the export lines in http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_from_source_on_Linux
didn't helped anything. i was a file called wcwin.m4 missing and i found out that this file exists only in the called package. well and it works now...

--Ano