User forums > Help

Does backtrack work in CodeBlocks?


I just downloaded and built the latest CVS version. I started looking into the backtrace feature of debugger plugin. It does not work. I don't remember if it worked on 1.0FinalBeta (or I even tried it...).

I traced the code into C::B parsing of GDB output, everything seems to be correct. the stack frame was valid and had all the available information. But when it was added to the wxListCtrl, nothing showed up. Wierd. So everytime I open backtrace dialog, all I get is a blank dialog box, nothing.....

Here's what my system configuration:
MinGW/GCC all components updated to latest candidates.
GCC 3.4.4
GDB 6.3


I noticed it and fixed it yesterday (here). Try updating again, as anonymous CVS lags a few hours behind ;)
The problem was that the list was cleared and its columns deleted too. Without columns, no way to display info  :oops:


Thanks. I managed to fix my source with the hint you gave without going to CVS. I wish I knew wxWindows better, but I am definitely improving.


[0] Message Index

Go to full version