Author Topic: Linking wx with Gcc  (Read 5082 times)

mercury

  • Guest
Linking wx with Gcc
« on: June 16, 2005, 06:03:13 pm »
Hi!
I'm doing my first project with wx in windows. After I've set all directories for the includes in the compiler options I get an error saying lib wx can't be found ("-lwx cannot be found"). So any ideas how to link?

Best regards to you all,
George

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Linking wx with Gcc
« Reply #1 on: June 16, 2005, 06:34:21 pm »
Maybe they're not found because you didn't download them ;-)

(No, Code::Blocks does NOT include wx libraries. You have to download them and install them by yourself) Try going to the wxWidgets forums. Good luck! :)

Offline Urxae

  • Regular
  • ***
  • Posts: 376
Linking wx with Gcc
« Reply #2 on: June 17, 2005, 10:36:29 am »
If you have downloaded and compiled it, are you sure it's called 'wx'? After I compiled wxWidgets 2.4.2 (withthe provided makefile), the library I needed was 'wxmsw242', not 'wx'.

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Linking wx with Gcc
« Reply #3 on: June 17, 2005, 11:25:47 am »
it is intended to replace the -lwx with the appropriate library name, you are using for your/this project.
the lib names depend on the used version of Wxwidgets and the various build flavours (dll, static, ... )