Author Topic: Improving "bootstrap"  (Read 3421 times)

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Improving "bootstrap"
« on: September 19, 2006, 02:33:05 pm »

I've done a small patch to improve the bootstrap script so that
it will honour any environment variables with programs to use.
Also made it recognize "glibtool" and "glibtoolize" for Mac OS X,
so you can go something like this without having to reinvent it:

Code
AUTOMAKE=automake-1.7 ACLOCAL=aclocal-1.7 ./bootstrap
(this assumes that you have installed automake-1.7.9 in /usr/local, and
copied /usr/share/aclocal/libtool.m4 over to /usr/local/share/aclocal-1.7)


This and the other patches should make it work "out of the box" ?
(since Mac people have been having lots of troubles with autotools)

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884