Author Topic: GDB Breakpoints not working  (Read 4360 times)

Offline crzysdrs

  • Single posting newcomer
  • *
  • Posts: 7
GDB Breakpoints not working
« on: September 13, 2006, 05:05:27 am »
Now I know you have probably heard this before but I am getting "No Source file named X". So, I basically can't use breakpoints.  I dug all through out this forum and found solutions that usually said use gdb 6.3. I can gaurentee that those files exist.

Code
Debugger name and version: GNU gdb 6.4
No source file named /home/crzysdrs/eporg_codebase/main.cpp.
Breakpoint 1 (/home/crzysdrs/eporg_codebase/main.cpp:40) pending.
No source file named /home/crzysdrs/eporg_codebase/main.cpp.
Breakpoint 2 (/home/crzysdrs/eporg_codebase/main.cpp:29) pending.
In main () ()

So I downgraded and yet I still see the same result.
Code
Debugger name and version: GNU gdb 6.3
No source file named /home/crzysdrs/eporg_codebase/main.cpp.
Breakpoint 1 (/home/crzysdrs/eporg_codebase/main.cpp:40) pending.
No source file named /home/crzysdrs/eporg_codebase/main.cpp.
Breakpoint 2 (/home/crzysdrs/eporg_codebase/main.cpp:38) pending.

Running Gentoo Linux, SVN download as of earlier today.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: GDB Breakpoints not working
« Reply #1 on: September 13, 2006, 03:44:50 pm »
I suppose you have enabled compiling with debug symbols for your projects and have cleanly rebuilt your projects at least once?
Be patient!
This bug will be fixed soon...

Offline crzysdrs

  • Single posting newcomer
  • *
  • Posts: 7
Re: GDB Breakpoints not working
« Reply #2 on: September 13, 2006, 05:48:13 pm »
Thank you very much. I knew it was something obvious I was missing. I really appreciate it, it is quite difficult to debug things when you cannot step through them.