Author Topic: Problem with cvs version. Useing wxwidget 2.6 Some sultions  (Read 11743 times)

Offline frog-o

  • Multiple posting newcomer
  • *
  • Posts: 61
I downloaded a black cvs version of codeblock from cvs  and it really goofed up.  I won't even compile.

here are some of the thing i did to fix some of problem.

The .cbp for wxwidget 2.6.0  need updateing and they need to remove
all of Tinyxlms.cpp

the need to remove
lst->Clear();
from BacktraceDlg.cpp

this would alow it to compile but then it has problem with the icon in 16 x16 mode with transperance not enabled on them.

There default tree control dose not display also.
 
when you close a pogrm it say that it can't find WXBITMAP_STD_COLOURS in .rc  a have wxwidgets include path in both my resore dir path  and compiler dir path

has anyone been able to fix the problem with the tree or any of the problem I mettion?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #1 on: May 25, 2005, 07:39:06 pm »
As mentioned many many times already, wxWidgets-2.6.0 is not officially supported for use with Code::Blocks. The provided files exist only for your convenience and they may not always be up-to-date.

Yiannis.
Be patient!
This bug will be fixed soon...

DreadNot

  • Guest
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #2 on: May 25, 2005, 08:02:35 pm »
Yiannis,

For those that are interested in wxWidgets 2.6.0, could you discuss the points of difference between the "CodeBlocks.cbp" and the "CodeBlocks-wx2.6.0.cbp".  Unsuspecting individuals may think that all CVS project files should always be up-to-date and compilable.  I know this is minor issue, but it should be useful.

Also, what zip program are you using for "update" and where do we get it?  And/Or what is the -j9 switch?

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #3 on: May 25, 2005, 08:19:17 pm »
As i've noticed there's one thing missing inside c::b 2.6 project - TiXml target has missing compiler defines - these are set inside default project correctly. After copying that I had no problems with compiling under wx 2.6 with one small correction:

Quote
the need to remove
lst->Clear();
from BacktraceDlg.cpp


It should be lst->ClearAll();

It should work fine wor both wx 2.4 and 2.6 (official manuals for 2.4 and 2.6 declare this function, coudn't even find Clear inside 2.4)

Hope this will help

DreadNot

  • Guest
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #4 on: May 25, 2005, 08:32:11 pm »
My last compile from CVS on wx2.6.0 didn't have any problems with tinyxml.  It did have problems with the debugger as it is in active development and not all the files were present in the project.  No problem to add them.  Thanks for the "ClearAll".  I thought it might be, but was unsure about the diff between Clear() and ClearAll().

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #5 on: May 25, 2005, 09:48:09 pm »
Quote
Unsuspecting individuals may think that all CVS project files should always be up-to-date and compilable. I know this is minor issue, but it should be useful.

DreadNot, "Unsuspecting individuals" who wish to build Code::Blocks from source, should read the accompanying README.* files and, in this case, the README-wx2.6.0 which mentions that wx2.6.0 is not officially supported :)

Quote
Quote
the need to remove
lst->Clear();
from BacktraceDlg.cpp

It should be lst->ClearAll();

Thanks, I 've put this in CVS.

Yiannis.
Be patient!
This bug will be fixed soon...

DreadNot

  • Guest
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #6 on: May 26, 2005, 07:12:24 am »
True enough  :D .

Offline frog-o

  • Multiple posting newcomer
  • *
  • Posts: 61
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #7 on: May 26, 2005, 03:27:12 pm »
Are you saying you are going to ignore the error that pop up in wxwidget 2.6 compiles.  I thought the devolpment form were the place where we try to fix these issues.  (we are the devolpers).  I thought we where sopused to discussion thing like this on the form inorder to bug track what might be a problem witch i try to do here.   It is fine if you don't want to help mandrave but please don't tell other pepole not to becuase it is unsoported.  I don't think you want to keep use 2.4 do you?

DreadNot

  • Guest
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #8 on: May 26, 2005, 08:27:27 pm »
He did fix it.  Get latest CVS.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #9 on: May 26, 2005, 08:49:32 pm »
DreadNot: YAY! :D

And frog-o, I want as much as you to start dev'ing with 2.6. Why don't we start a "Converting wxwidgets from 2.4 to 2.6" forum and post all the problems there? This way we'll be more informed, and hopefully a charitative stranger might give us a hand.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #10 on: May 26, 2005, 09:29:51 pm »
Quote from: frog-o
Are you saying you are going to ignore the error that pop up in wxwidget 2.6 compiles. I thought the devolpment form were the place where we try to fix these issues. (we are the devolpers). I thought we where sopused to discussion thing like this on the form inorder to bug track what might be a problem witch i try to do here. It is fine if you don't want to help mandrave but please don't tell other pepole not to becuase it is unsoported. I don't think you want to keep use 2.4 do you?

Ahh, once again I say one thing and you understand another...
I said:
Quote from: mandrav
As mentioned many many times already, wxWidgets-2.6.0 is not officially supported for use with Code::Blocks. The provided files exist only for your convenience and they may not always be up-to-date.

Did I say anywhere "don't use wx2.6"???
Did I say "I don't care about wx2.6"???
Did I say "don't discuss about wx2.6"???

I just said "it's not officially supported".
In other words: "I give you the files. They may not be always up-to-date but they 'll be good for a starting point. Ask anything about it but don't expect immediate response from me. Immediate attention is given to the officialy used version (wx2.4)".

But I guess, once again, it's just my poor use of English language...

Yiannis.
Be patient!
This bug will be fixed soon...

Offline frog-o

  • Multiple posting newcomer
  • *
  • Posts: 61
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #11 on: May 27, 2005, 01:51:34 pm »
for somerson i did not see this

Quote
The provided files exist only for your convenience and they may not always be up-to-date.


This is my fault of not reading thing thoughly.  I oppologize and say i sorry for mis-understanding.  
[/quote]

Offline frog-o

  • Multiple posting newcomer
  • *
  • Posts: 61
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #12 on: May 27, 2005, 05:50:44 pm »
DreadNot
said
Quote

He did fix it. Get latest CVS.

dose this mean the bugs for the linux virson has been fix or does it still need work?  He could just mean the bugs for the windows version?
 If not i would love to help rickg22 ,  but i am  verry limmited on my knowlage.   I still have to try getting codeblock compile useing gentoo linux on my colinux system in windows.

Offline heromyth

  • Multiple posting newcomer
  • *
  • Posts: 98
    • http://
Problem with cvs version. Useing wxwidget 2.6 Some sultions
« Reply #13 on: July 04, 2005, 03:09:47 pm »
In WinXP, I have compiled C::B CVS. Below is the difference of CodeBlocks-wx2.6.0.cbp between that I am using and that exists in CVS. Hope it be useful for you. Run in Win2000, it will crash.

Code

*** codeblocks\src\CodeBlocks-wx2.6.0.cbp Sun May 29 00:26:18 2005
--- codeblocks\src\CodeBlocks-wx2.6.0-my.cbp Mon Jul 04 20:53:24 2005
***************
*** 99,104 ****
--- 99,105 ----
  <Compiler>
  <Add option="-DBUILDING_PLUGIN"/>
  <Add option="-D_WINDLL"/>
+ <Add option="-DNDEBUG"/>
  <Add directory="sdk"/>
  <Add directory="plugins\astyle\astyle"/>
  </Compiler>
***************
*** 309,315 ****
  <Option output="codeblocks-wx2.6.0.dll"/>
  <Option working_dir="."/>
  <Option object_output=".objs\2.6.0"/>
! <Option deps_output="C:\Devel\codeblocks\src\.deps"/>
  <Option external_deps=""/>
  <Option type="3"/>
  <Option compiler="0"/>
--- 310,316 ----
  <Option output="codeblocks-wx2.6.0.dll"/>
  <Option working_dir="."/>
  <Option object_output=".objs\2.6.0"/>
! <Option deps_output=".deps"/>
  <Option external_deps=""/>
  <Option type="3"/>
  <Option compiler="0"/>
***************
*** 351,357 ****
  </Build>
  <Compiler>
  <Add option="-Wall"/>
- <Add option="-g"/>
  <Add option="-pipe"/>
  <Add option="-mthreads"/>
  <Add option="-fno-pcc-struct-return"/>
--- 352,357 ----
***************
*** 386,401 ****
  <Option link="0"/>
  <Option target="src"/>
  </Unit>
- <Unit filename="plugins\astyle\asstreamiterator.cpp">
- <Option compilerVar="CPP"/>
- <Option target="plugin_Astyle"/>
- </Unit>
- <Unit filename="plugins\astyle\asstreamiterator.h">
- <Option compilerVar=""/>
- <Option compile="0"/>
- <Option link="0"/>
- <Option target="plugin_Astyle"/>
- </Unit>
  <Unit filename="plugins\astyle\astyle\ASBeautifier.cpp">
  <Option compilerVar="CPP"/>
  <Option target="plugin_Astyle"/>
--- 386,391 ----
***************
*** 404,413 ****
  <Option compilerVar="CPP"/>
  <Option target="plugin_Astyle"/>
  </Unit>
- <Unit filename="plugins\astyle\astyle\ASResource.cpp">
- <Option compilerVar="CPP"/>
- <Option target="plugin_Astyle"/>
- </Unit>
  <Unit filename="plugins\astyle\astyle\INSTALL.TXT">
  <Option compilerVar=""/>
  <Option compile="0"/>
--- 394,399 ----
***************
*** 832,837 ****
--- 818,833 ----
  <Option link="0"/>
  <Option target="plugin_CompilerGCC"/>
  </Unit>
+ <Unit filename="plugins\compilergcc\compilerOW.cpp">
+ <Option compilerVar="CPP"/>
+ <Option target="plugin_CompilerGCC"/>
+ </Unit>
+ <Unit filename="plugins\compilergcc\compilerOW.h">
+ <Option compilerVar=""/>
+ <Option compile="0"/>
+ <Option link="0"/>
+ <Option target="plugin_CompilerGCC"/>
+ </Unit>
  <Unit filename="plugins\compilergcc\compilererrors.cpp">
  <Option compilerVar="CPP"/>
  <Option target="plugin_CompilerGCC"/>
***************
*** 1652,1657 ****
--- 1648,1663 ----
  <Option link="0"/>
  <Option target="sdk"/>
  </Unit>
+ <Unit filename="sdk\editorlexerloader.cpp">
+ <Option compilerVar="CPP"/>
+ <Option target="sdk"/>
+ </Unit>
+ <Unit filename="sdk\editorlexerloader.h">
+ <Option compilerVar=""/>
+ <Option compile="0"/>
+ <Option link="0"/>
+ <Option target="sdk"/>
+ </Unit>
  <Unit filename="sdk\editormanager.cpp">
  <Option compilerVar="CPP"/>
  <Option target="sdk"/>
***************
*** 1872,1877 ****
--- 1878,1889 ----
  <Option link="0"/>
  <Option target="sdk"/>
  </Unit>
+ <Unit filename="sdk\openfilestree.h">
+ <Option compilerVar=""/>
+ <Option compile="0"/>
+ <Option link="0"/>
+ <Option target="sdk"/>
+ </Unit>
  <Unit filename="sdk\personalitymanager.cpp">
  <Option compilerVar="CPP"/>
  <Option target="sdk"/>
***************
*** 2710,2718 ****
  </Unit>
  <Unit filename="src\resources\resources.rc">
  <Option compilerVar="WINDRES"/>
  <Option compile="0"/>
  <Option link="0"/>
- <Option objectName="src\resources\resources.res"/>
  <Option target="src"/>
  </Unit>
  <Unit filename="src\startherepage.cpp">
--- 2722,2740 ----
  </Unit>
  <Unit filename="src\resources\resources.rc">
  <Option compilerVar="WINDRES"/>
+ <Option objectName="src\resources\resources.res"/>
+ <Option target="src"/>
+ </Unit>
+ <Unit filename="src\resources\start_here\cb_logo.jpg">
+ <Option compilerVar=""/>
+ <Option compile="0"/>
+ <Option link="0"/>
+ <Option target="src"/>
+ </Unit>
+ <Unit filename="src\resources\start_here\start_here.html">
+ <Option compilerVar=""/>
  <Option compile="0"/>
  <Option link="0"/>
  <Option target="src"/>
  </Unit>
  <Unit filename="src\startherepage.cpp">