Author Topic: Console window appears during compilation  (Read 3367 times)

Offline Koshmaar

  • Single posting newcomer
  • *
  • Posts: 4
  • I'm not complete idiot - part's of me are missing
    • Homepage
Console window appears during compilation
« on: July 02, 2006, 09:01:55 pm »
Hi, I'm new user of Code::Blocks, and having used DevCpp before for over 1,5 year gives me good overall impression of C::B in comparison to Dev. Good luck guys, I hope you'll get to RC3 soon :-)

However, I have one little problem with night build from 30 june (I use it on WinXP with GCC/MinGW) - console window appears during compilation, it opens in fullscreen, and after few seconds it dissapears - obviously, it's very irritating. I remember in DevCpp there was an option to disable this, but I couldn't find anything like that in C::B. Googling gave nothing, searching those forums gave nothing, the same with C::B main site.

So, do you have any suggestions? Thanks in advance :-)

Offline Koshmaar

  • Single posting newcomer
  • *
  • Posts: 4
  • I'm not complete idiot - part's of me are missing
    • Homepage
Re: Console window appears during compilation
« Reply #1 on: July 04, 2006, 12:44:18 am »
OK, I found on MinGW FAQ that I should add -mwindows to the linker commandline. However, it didn't solve my problem :-/ I added it to project's linker commandline, target's linker commandline and even compiler commandline, but there's no difference,  console appears as before. So, do you have any thoughts what might be wrong here? Please help, it's the only thing which prevents me from using C::B.

sethjackson

  • Guest
Re: Console window appears during compilation
« Reply #2 on: July 04, 2006, 03:07:29 am »
Hi, I'm new user of Code::Blocks, and having used DevCpp before for over 1,5 year gives me good overall impression of C::B in comparison to Dev. Good luck guys, I hope you'll get to RC3 soon :-)

However, I have one little problem with night build from 30 june (I use it on WinXP with GCC/MinGW) - console window appears during compilation, it opens in fullscreen, and after few seconds it dissapears - obviously, it's very irritating. I remember in DevCpp there was an option to disable this, but I couldn't find anything like that in C::B. Googling gave nothing, searching those forums gave nothing, the same with C::B main site.

So, do you have any suggestions? Thanks in advance :-)

Well that is just plain weird.  :shock: You can turn it off. Project -> Properties -> Targets -> Pause when execution ends (uncheck it).

This probably won't fix your problem though.

Offline Koshmaar

  • Single posting newcomer
  • *
  • Posts: 4
  • I'm not complete idiot - part's of me are missing
    • Homepage
Re: Console window appears during compilation
« Reply #3 on: July 04, 2006, 10:13:34 pm »
OK, I found on MinGW FAQ that I should add -mwindows to the linker commandline.

False alert - that part on MinGW FAQ was reffering to the console window which appears when running the properly compiled program - not compiler.

Quote from: sethjackson
Well that is just plain weird. You can turn it off. Project -> Properties -> Targets -> Pause when execution ends (uncheck it).

This probably won't fix your problem though.

Sorry, but you must have misunderstood me. I'm not not talking about console window which appears when running the properly compiled and linked program.


I'm using MinGW 3.4.2 - and DevCpp is using the same compiler. I tested DevCpp with option that allows and supressess the console window from appearing, and the only difference in commandline passed to gcc was -mwindows (?) weird.

...

I don't know what to say. Ok, I won't write here all things I tried, however, you should know that I ordered C::B to compile custom Makefile (generated by DevCpp ;-) ) and it compiles it ok without any additional windows appearing, nor any mwindows attached.


Though it works, I'd prefer not to build individual makefiles for all projects (also, setting options like include directories from IDE is far easier and flexible) - so, if anyone could tell me how to get this !#$*@%^& to work...