User forums > Using Code::Blocks

Strange Startup Error


I currently get an error message:

"file 'C:\WINDOWS/MinGW.ini', line 2: '=' expected."

in a small popup message every single time I start up CodeBlocks.
This appears together with the compilers auto-detection window.

I haven't a clue what exactly triggered this, but I was trying to compile a DLL using a custom Makefile. In the process, I was closing and starting up CodeBlocks a number of times.

I've tried reinstalling CodeBlocks and MinGW, deleted CodeBlocks related registry keys (not sure if I spotted all of them) but the message appears if ClodeBlocks and MinGW are both installed.

Any ideas?

question - why did you close and started up codeblocks a number of times? Was the DLL a codeblocks plugin or something? Well, try deleting the mingw.ini and see what happens. OH wait, you might want to show here the contents of such mingw.ini.

If you want, post the contents of c:\mingw.ini here so we can fix this error message.
After you do that, it's safe to delete it, and the error will go away.


OK, replying as a registered user.

The reason I was opening/closing CodeBlocks a number of times was because I was trying to figure out a problem I was having with output paths and make targets CodeBlocks was setting when compiling.
(I will post details in a different post).

I have tried uninstalling Codeblocks, deleting registry keys, and restarting the computer.
Reinstalled Codeblocks and the startup error no longer appears.

The contents of "MinGW.ini" is and always has been:

InstallPath MinGW=c:\MinGW

no longer appears? :-/ Darn! It's non-reproduceable now. Grrrr. OH well.


[0] Message Index

Go to full version