Author Topic: Can't compile wxWidgets program  (Read 5054 times)

Offline Jamiil

  • Single posting newcomer
  • *
  • Posts: 7
Can't compile wxWidgets program
« on: May 04, 2005, 02:50:22 pm »
After creating a 'wxWidgets' project and using all the default options, I tried to compile it, but I get an error saying that *non* and I mean not even one of the 'wx/*.*' files where found in my computer. I did a search for any of the files, but to no avail.

Does anyone know what I did wrong at the time of the installation or do wrong at the time of the compilation?

TIA  :(  :shock:

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Can't compile wxWidgets program
« Reply #1 on: May 04, 2005, 08:07:43 pm »
You didn't do anything wrong (as far as I know, and as far as I can see now)
I think you did a fresh full installation of C::B didn't you?
You didn't install wxWidgets, did you?
if you did a fresh full install (beta 7) and not installed wxWidgets, then that is the problem. wxWidgets is not being deliverd with beta 7 of C::B
Hopefully it is being delivered with beta 8.
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Can't compile wxWidgets program
« Reply #2 on: May 04, 2005, 11:51:27 pm »
No, it won't. At least as far as i know.
After all you only have to download the wxwidgets installer,  and erm... compile them, and erm... :(

Anyway, things will be easier when devpacks support arrives :D.Mandrav's working on it, and another guy (forgot his name sorry) is working separately on a plugin (let the race begin! :P )

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Can't compile wxWidgets program
« Reply #3 on: May 05, 2005, 08:15:47 am »
Rick is right. We are not going to distribute wxWidgets binaries. There are just too many options: static lib, dll, unicode, non-unicode, wx2.4.2, wx2.6, monolithic, etc.

Regarding devpacks:
I have already written the decompression code for devpacks. All that's left is make a gui for it. I don't know, though, if it will make it in the next release.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline Jamiil

  • Single posting newcomer
  • *
  • Posts: 7
Can't compile wxWidgets program
« Reply #4 on: May 16, 2005, 06:56:34 pm »
Well, thanks for the info. But, now that I have installed wxWidgets-2.6.0, how do I set it up so that I can compile the default program?

Thanks all, every little help is very much appreciated.