User forums > Help

Resources problem (windres.exe >> MinGW) Typo?

<< < (2/2)

Plz, can anyone help, I've tried lots of things and it still doesn't works...

The problem seems to be that GDB isn't understanding "code\main.cpp" as 'main.cpp' in the 'code' folder, it's understanding as a file named "code\main.cpp" (just a guess though)

I've copied the project and put all the sources in the same folder as the project and it works, but I don't like keeping it that way because it's very messy in a 50+ source files project...

Can anyone help me?

Oh, and I've tried the search feature...

David Perfors:
It is very strange, but I think GDB can't handle the "\" sign. Do you have "\" somewhere in your includes? if so, try changing it to the linux style "/". That is the only thing I can think of...

That could be the reason, but the problem is that the '\' is added by CB itself and I can't find a way to bypass it (I've tried changing '\' into '/' inside the .cbp file with no success)... All my includes and etc use just the filename (they are like '#include "main.h"' no 'code\'), so I'm a bit lost...

Thanks for the reply

my solution is, until the debugger plugin is better implemented, to use the commandline gdb.

It takes a bit to get used to it, but hey, when you're trying to hunt segfaults for 2 hours, it's easier everytime :P


[0] Message Index

[*] Previous page

Go to full version