User forums > General (but related to Code::Blocks)

Problem with SFML 2.0 libraries

<< < (2/5) > >>

Qday:

--- Quote ---How did you link this DLL? Directly or using *.a file?

--- End quote ---

I dont know the terminology but the dll is in the same folder as my .exe file

stahta01:
Post the current full re-build log.
Edit: Add link to FAQ https://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

Tim S.

nenin:

--- Quote from: Qday on June 04, 2024, 03:58:34 pm ---
--- Quote ---How did you link this DLL? Directly or using *.a file?

--- End quote ---

I dont know the terminology but the dll is in the same folder as my .exe file

--- End quote ---
exe found dll, but dll did not provide required function. It means that you linked incorrect dll. Linking of the dll can be done in few manners for mingw gcc:
1. Static using interface lib with extension *.a
2. Static using dll by itself (from my experience  it is better)
3. Dynamic by call dll and function from the code.
Something is wrong in your case.

Qday:

--- Quote from: stahta01 on June 04, 2024, 06:23:45 pm ---Post the current full re-build log.
Edit: Add link to FAQ https://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28general%29#Q:_How_do_I_report_a_compilation_problem_on_the_forums.3F

Tim S.

--- End quote ---
Sorry for the late response. I hope you can still help me .


--- Code: ----------------- Clean: Debug in SFML_01 (compiler: GNU GCC Compiler)---------------

Cleaned "SFML_01 - Debug"

-------------- Build: Debug in SFML_01 (compiler: GNU GCC Compiler)---------------

g++.exe -Wall -g -IC:\Dev\SFML-2.6.1\include -c D:\CPP\SFML_01\main.cpp -o obj\Debug\main.o
g++.exe -LC:\Dev\SFML-2.6.1\lib -o bin\Debug\SFML_01.exe obj\Debug\main.o  -static -static-libgcc  -lsfml-audio-d -lsfml-graphics-d -lsfml-main-d -lsfml-network-d -lsfml-system-d -lsfml-window-d -mwindows
Output file is bin\Debug\SFML_01.exe with size 2.37 MB
Process terminated with status 0 (0 minute(s), 1 second(s))
0 error(s), 0 warning(s) (0 minute(s), 1 second(s))
Build log saved as:
file://D:/CPP/SFML_01/SFML_01_build_log.html


--- End code ---


Is it what you were asking for?

stahta01:
That is the build log I was asking for.

Are you now using an Compiler that is compatible with the library? What compiler are you using?
Because I did not see a build error. Are you having a run-time problem?

Tim S.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version