User forums > General (but related to Code::Blocks)

patch for the autotools build to work with Msys2/MinGW32

(1/2) > >>

reckless:
The Msys2 devs dont want it since they are deprecating win32 but for those of us who still use 32 bit sometimes this fixes the build.

the problem as noticed by others is that windres on 32 bit mingw gets passed -mthreads via the WX_CXXFLAGS flag.
changed it to WX_CPPFLAGS as both return the same minus the -mthreads flag.

Grit Clef:
Good! Simple but useful for me.

ollydbg:

--- Quote from: reckless on May 16, 2024, 05:30:12 pm ---The Msys2 devs dont want it since they are deprecating win32 but for those of us who still use 32 bit sometimes this fixes the build.

the problem as noticed by others is that windres on 32 bit mingw gets passed -mthreads via the WX_CXXFLAGS flag.
changed it to WX_CPPFLAGS as both return the same minus the -mthreads flag.

--- End quote ---

Hi, reckless, long time no see. Thanks.

I'm not using the 32 bit windows system, some of my PCs are still Win7 64bit, and it seems msys2 are dropping support for those systems.

BTW, can you have a look at this post:

Code::Blocks / Tickets / #1461 Fix building codeblocks on MinGW-w64 aarch64

I'm still hoping Code::Blocks could be built under the MinGW64 port. (as you patch, it supports building C::B on the MinGW32 port)

reckless:
mingw64 works fine now not sure about aarch but i can have a look :)

reckless:
ah wait you mean for older OS like win7 ? well it should still be possible by setting the WIN32_WINNT flag to 0x601 and building it with mingw64.
i do have a prebuilt package you can try out if you want ?.
otherwise you probably have to build the package yourself but they did include mingw64 in the PKGBUILD now but it is not avaliable as a pacman package yet it seems.

Navigation

[0] Message Index

[#] Next page

Go to full version