Author Topic: How to force MingW to use 32bit lib instead of 64bit libs  (Read 925 times)

Offline deebeesp

  • Single posting newcomer
  • *
  • Posts: 1
How to force MingW to use 32bit lib instead of 64bit libs
« on: April 01, 2024, 09:06:05 pm »
When trying to cross-compile for 32bit Windows on Linux using MingW I get the following error:

Code
/usr/bin/i686-w64-mingw32-ld: /usr/x86_64-w64-mingw32/lib/libmingw32.a: error adding symbols: file format not recognized

It's obvious that MingW is trying to 64 bit libs instead of 32 bit libs. It's a fairly straightforward issue but I have no idea how to fix. I already tried setting the search directories for the 32 bit lib folder but that didn't work. The -m32 flag also didn't quite help.

Any help appreciated.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7625
    • My Best Post
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org