User forums > Help

How to force MingW to use 32bit lib instead of 64bit libs


When trying to cross-compile for 32bit Windows on Linux using MingW I get the following error:

--- Code: ---/usr/bin/i686-w64-mingw32-ld: /usr/x86_64-w64-mingw32/lib/libmingw32.a: error adding symbols: file format not recognized
--- End code ---

It's obvious that MingW is trying to 64 bit libs instead of 32 bit libs. It's a fairly straightforward issue but I have no idea how to fix. I already tried setting the search directories for the 32 bit lib folder but that didn't work. The -m32 flag also didn't quite help.

Any help appreciated.


Please post a full re-build log; and, maybe some will see a problem.

Tim S.


[0] Message Index

Go to full version