User forums > Help

Fresh install of codeblocks seems to have messed up paths in some projects

(1/2) > >>

I installed codeblocks 3 years ago but had an occasional bug that had been reported and now fixed so I reinstalled codeblocks.

Now some of my projects aren't working.  The really strange thing is that some, which are very similar still are.

The projects that aren't working are failing to find data files (images mostly) which are coded to have paths that lead from where the project file is.   From where the project file is, the executable is in /bin/debug/???.exe

I can also move the .exe to the folder the project file is in and everything works correctly.   I don't put the exe where it is, it shows up there after being compiled and, up until today, it worked fine from its compiled location or in the folder the project-workspace is in.

I have looked through project settings/compiler settings/etc and even made changes hoping to correct things but I'm afraid I will break other things if I keep trying to fix it on my own.

of 5 projects.
1. most used - doesn't get any data files or images loaded but works perfectly if I move the exe into the folder the project is in and execute it from file viewer
2. old version of the most used - works completely as if nothing happened
3. 2nd most used project - which edits image files.  It isn't loading data/image files either.
4. project that doesn't use images at all but does use data files appears to be working correctly
5. a project I wrote months ago and haven't touched since, which uses one large image file is not loading the image.   I had no reason to change it after it was working properly.

so 2 projects still work 3 don't

the  "bug" I was trying to fix by updating my codeblocks was one that told me the project was compiling when I tried to shut down codeblocks (but it wasn't compiling)  I suspect that could be the common denominator.   I might have gotten that bug on each of the programs that isn't working now the last time I had them open.  I used task manager to force quit codeblocks whenever I got the bug.   But then if i restarted it my programs worked normally before.   I got the bug the last time I tried to shut that program down.  Then I updated codeblocks.

this is the bug I was trying to fix

Perhaps I should have put this in a bug reports section but I'm hoping there is a simple fix.

Which nightly build of Code::Blocks did you install?,20.0.html

Tim S.

Version          : 20.03-r11983
is 11983 the nightly build?
My previous version was downloaded on Jan 20, 2022 - codeblocks-20.03-setup.exe

I checked the nightly build number before downloading the new version (on march 24, 2024) and I thought it started with a 2, as in 20000.   Would that mean I didn't successfully reinstall?

Does this mean I need to download wxwigits, winwm10.dll, and wxmsw28u_gcc_cb.dll and other things mentioned in the nightly build?

I also didn't "save" the download I just "opened" it(iirc, + it isn't in my downloads folder).   At that point i just accepted default options.

I got my updated version of codeblocks from this link
and I think i chose the codeblocks-20.03mingw-setup.exe

i'm not positive of that.  I know I have a mingw folder where iirc i put my opengl.a files so it looks like that would be the right download.  c:\program files\codeblocks\mingw\include.   If not it was the codeblocks-20.03-setup.exe.

btw thank you for codeblocks and your help fixing this


--- Quote from: Vigor on March 26, 2024, 09:31:02 pm ---Version          : 20.03-r11983
is 11983 the nightly build?

--- End quote ---

No, that was the last release and the link you posted was after that release; therefore, it does not have the fix you said you needed.

You need to follow the nightly build directions in link to use the Windows nightly build.

Tim S.


[0] Message Index

[#] Next page

Go to full version