Author Topic: Input Delay in Editor  (Read 1613 times)

Offline coconok

  • Single posting newcomer
  • *
  • Posts: 1
Input Delay in Editor
« on: February 18, 2024, 05:34:14 pm »
Hey guys,

while I write in the editor from code blocks I always get an input delay from the keyboard. My curser from the mouse doesnt stuck and I can click on everything. It happened random and it goes away after a few minutes or when I restart code blocks. I have the most things on default. I 've found some tips in the www but nothing really helped, like playing with the input delay in the settings.

My System Win 10, codeblocks is updated to newest build.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5930
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Input Delay in Editor
« Reply #1 on: February 19, 2024, 03:03:06 am »
To check which causes the delay issue, I think there are some steps:

1, you can remove or disable all the plugins, and see whether this issue still happens.
2, you can enable the plugins one by one, and see whether this issue happens after some plugin get activated.

Tell use more details about your C::B, such as revision, you OS and other things. Thanks.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline nenin

  • Almost regular
  • **
  • Posts: 227
Re: Input Delay in Editor
« Reply #2 on: February 23, 2024, 07:36:05 am »
Hey guys,

***codeblocks is updated to newest build.
Just in case: check if you have corresponding version of the wxWidget dlls. Also such effect might appear if you have installed something like keylogger or software with problematic global shortcut keys.