User forums > General (but related to Code::Blocks)

wxWidgets location doesn't work when portable


Hello everyone.

I have a flash drive on which I run Code::Blocks through CbLauncher.exe. I also have wxWidgets-3.0.5 on the same drive.
I tried to create a global variable for it as $(APPPATH)\wxWidgets-3.0.5, but when I create a new project, it throws me this error:

--- Quote ---Script error
The path you entered seems valid, but this wizard can't locate wxWidgets' files in it...

--- End quote ---
However it works when I directly specify it including the drive letter.

What can be done about this?
Sincerely thank you.

Miguel Gimenez:
The wizard appends "/include/wx/wx.h" to the address you gave, if the file does not exist it emits that message.

Have you tried $(APPPATH)/wxWidgets-3.0.5?

$(APPPATH)/wxWidgets-3.0.5 also doesn't work. "wxWidgets-3.0.5\include\wx\wx.h" does exist.

Miguel Gimenez:
Then the value of $(APPPATH) may be different from expected. Try modifying the script so it shows the value.

Simply trying $(APPPATH)wxWidgets-3.0.5 worked. Thanks for help though.


[0] Message Index

Go to full version