Author Topic: Help needed, configure error  (Read 4962 times)

Offline lengfeih

  • Single posting newcomer
  • *
  • Posts: 2
Help needed, configure error
« on: November 23, 2016, 05:32:57 pm »
Hi, I am trying to install CB 16.01 from source code. I got the following error message when running ./configure.

checking for pkg-config... yes
./configure: line 20412: PKG_PROG_PKG_CONFIG: command not found
You don't have pkg.m4 properly installed

I compile and installed the automake myself. The linux system is pretty old (Red hat Enterprise release 5.0). I don't have the root authority so I need to compile and install everything myself.

$ aclocal --print-ac-dir
/home/coldfire/Tool/share/aclocal
$ ls /home/coldfire/Tool/share/aclocal
argz.m4  libtool.m4  ltdl.m4  lt~obsolete.m4  ltoptions.m4  ltsugar.m4   ltversion.m4  pkg.m4  README  wxwin.m4


Any help will be great.
Thanks
coldfire

Offline lengfeih

  • Single posting newcomer
  • *
  • Posts: 2
Re: Help needed, configure error
« Reply #1 on: November 23, 2016, 06:08:20 pm »
So far, I installed the following package

1. WxWidgets 3.0.2
2. autoconf-2.68
3. automake-1.13
4. pkg-config-0.25
5. libtool-2.2

jawi

  • Guest
Re: Help needed, configure error
« Reply #2 on: December 29, 2016, 03:00:30 pm »
try to run

autoreconf -vfi

in the source directory and than

./configure again.

Jan

Offline ouch

  • Almost regular
  • **
  • Posts: 223
Re: Help needed, configure error
« Reply #3 on: December 29, 2016, 09:36:36 pm »
Your version of pkg-config is pretty old (6 years according to: https://pkg-config.freedesktop.org/releases/ )

Maybe updating it will help?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13413
    • Travis build status
Re: Help needed, configure error
« Reply #4 on: December 29, 2016, 10:10:44 pm »
Why don't you try to install the el5 packages from here http://codeblocks.org/downloads/26 ?
rpm supports installing packages in different prefixes than the default, so this might work for you.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Jenna

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Help needed, configure error
« Reply #5 on: December 29, 2016, 11:06:59 pm »
Why don't you try to install the el5 packages from here http://codeblocks.org/downloads/26 ?
rpm supports installing packages in different prefixes than the default, so this might work for you.
I just tried it, and it does not work, because it's not relocatable.

Offline tigerbeard

  • Almost regular
  • **
  • Posts: 194
Re: Help needed, configure error
« Reply #6 on: December 19, 2023, 11:07:46 am »
autoreconf -vfi
./configure again.
I know its an old topic, but I also had a configure problem (not found src/include/Makefile.in") and make clean and update did not help. But running "autorecong -vfi" did the trick, then configure worked find.

Thanks!