User forums > Using Code::Blocks

Only terminal window came out when I try to run


Hello, I am quite new in using CB and is facing a problem where when I try to run my code, the output did not appear. Only the black terminal window.

I am using CB 20.03 MinGw and in Windows 11.

Before, all my projects can run smoothly until now, suddenly. I've tried running my previous project, no output came out. Tried running outside IDE, from the bin folder, nothing came out. I'm not sure if I clicked something while working on my current project.

I've tried uninstall and re-install back CB but nothing changes.

I've disabled my Antivirus, nothing changes.

Build logs:

-------------- Build: Debug in trying (compiler: GNU GCC Compiler)---------------

Target is up to date.
Nothing to be done (all items are up-to-date).

-------------- Run: Debug in trying (compiler: GNU GCC Compiler)---------------

Checking for existence: C:\Users\User\Desktop\trying\bin\Debug\trying.exe
Set variable: PATH=.;C:\Program Files\CodeBlocks\MinGW\x86_64-w64-mingw32\lib;C:\Program Files\CodeBlocks\MinGW\bin;C:\Program Files\CodeBlocks\MinGW;C:\Program Files\CodeBlocks\MinGW\bin\bin;C:\Windows\System32;C:\Windows;C:\Windows\System32\wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Users\User\AppData\Local\Microsoft\WindowsApps;C:\Users\User\AppData\Local\Programs\Microsoft VS Code\bin
Executing: "C:\Program Files\CodeBlocks/cb_console_runner.exe" "C:\Users\User\Desktop\trying\bin\Debug\trying.exe"  (in C:\Program Files\CodeBlocks\MinGW\x86_64-w64-mingw32\bin)
Process terminated with status -1073741510 (0 minute(s), 5 second(s))
I hope I have given enough information for my problem.

I've tried installing other IDE which is Dev CPP and tried running it. Same thing occured. Then, I code a simple "Hello world" on both IDE, the terminal display it fine. So I'm guessing it has something to do with my OpenGL setting but I couldn't figure out what. Anyone can help?


[0] Message Index

Go to full version