User forums > Help

selecting text breaks paste


When I select some text, then copy it, I can then paste it somewhere else.
When I select some text, then copy it, and then select something else, code::blocks starts thinking there is nothing in my clipboard, and paste does nothing. If I select some text and then paste, that text just gets deleted.
This is very annoying because if I want to replace some text with my clipboard, I can no longer select the bad text and paste in the good text.
Even If I just select one character, and then unselect the character, my code::blocks clipboard is still broken, until I copy some new text.

It is strange because even when Code::Blocks thinks my clipboard has nothing in it, I can switch to another program and paste the original copied text.
It is also strange because this only started happening around a week ago.

When I say "select text" I have tried mouse dragging, shift+arrow keys, or double clicking
When I say "copy" I have tried right click -> copy or ctrl+c or ctrl+x
When I say "paste" I have tried right click -> paste or ctrl+V

Code::Blocks version: 20.03
OS: Arch Linux x86_64
WM: KWin

I no longer can reproduce this bug.
Started working after a `pagman -Syu`

That had been broken a while ago for several weeks but has been fixed in trunk a few weeks ago. I had this with trunk of cb and wxwidgets on arch and ubuntu. If memory serves me, it was a wxwidgets bug.

I agree, that was very annoying. I use it all the time.


[0] Message Index

Go to full version