Author Topic: Can't create projects, the application closes  (Read 6232 times)

Offline BitProgrammer

  • Single posting newcomer
  • *
  • Posts: 1
Can't create projects, the application closes
« on: October 11, 2023, 10:28:20 pm »
I've been having a problem with the creation of projects, not its confection, but in the "create a new project". When I click in this button the application stops and in few seconds it closes itself (or is closed, I don't know). This happens without showing any error screen, just freezes and closes. After checking the Task Manager to see the use of resources, the application's process didn't show any anomaly and the other process keep running without any disturbance in any way.
I was running a Windows 10 Pro 22H2 as OS and the description of the code::block is Version: 20.03-r11983; SDK Version: 2.0.0; Scintilla Version: 3.7.5.

I'll like to know if this is a problem with the code::blocks or a problem with me(Configuration, PC and so on), and if that problem has precedent.
I would be grateful if someone could give me some information.

Obs:Yes, I have already tried restarting the computer and I have already tried reinstalling the program.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1603
Re: Can't create projects, the application closes
« Reply #1 on: October 12, 2023, 10:57:22 am »
1.- Check if this comment from ticket #1246 applies to your case:
Use an absolute path in the "Folder to create project" box. Default file location under"C:\Program files" is not writable for programs without administrator privileges, use p.e. C:\MyPrograms or a folder inside "My documents" or the desktop.

Inserting spaces or localized characters in the path or file name is not a good idea.

2.- Look if there is a codeblocks.rpt file in the same folder where codeblocks.exe resides and attach it here.

3.- Check the current nightly (it will not mess your current installation).